summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 03:08:49 +0100
committerSam James <sam@gentoo.org>2021-04-03 16:54:59 +0100
commit87b31524f9a546c261cc7d81cbed4069aaf3882d (patch)
treeb42e6bbbff01445bf58f2e9007f0c0a9b1aadab3 /net-analyzer/netperf/netperf-2.7.0-r2.ebuild
parentnet-analyzer/netcat: drop unused flag-o-matic in older (diff)
downloadgentoo-87b31524f9a546c261cc7d81cbed4069aaf3882d.tar.gz
gentoo-87b31524f9a546c261cc7d81cbed4069aaf3882d.tar.bz2
gentoo-87b31524f9a546c261cc7d81cbed4069aaf3882d.zip
net-analyzer/netperf: EAPI 7, eutils--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/netperf/netperf-2.7.0-r2.ebuild')
-rw-r--r--net-analyzer/netperf/netperf-2.7.0-r2.ebuild32
1 files changed, 16 insertions, 16 deletions
diff --git a/net-analyzer/netperf/netperf-2.7.0-r2.ebuild b/net-analyzer/netperf/netperf-2.7.0-r2.ebuild
index ac656a889e76..6a56ebb79e3c 100644
--- a/net-analyzer/netperf/netperf-2.7.0-r2.ebuild
+++ b/net-analyzer/netperf/netperf-2.7.0-r2.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit eutils flag-o-matic user
+EAPI=7
+
+inherit flag-o-matic user
DESCRIPTION="Network performance benchmark"
SRC_URI="ftp://ftp.netperf.org/${PN}/${P}.tar.bz2"
@@ -13,7 +14,13 @@ LICENSE="netperf"
SLOT="0"
IUSE="demo sctp"
-DEPEND=">=sys-apps/sed-4"
+PATCHES=(
+ "${FILESDIR}"/${PN}-fix-scripts.patch
+ "${FILESDIR}"/${PN}-2.6.0-log-dir.patch
+ "${FILESDIR}"/${PN}-2.7.0-includes.patch
+ "${FILESDIR}"/${PN}-2.7.0-space.patch
+ "${FILESDIR}"/${PN}-2.7.0-inline.patch
+)
pkg_setup() {
enewuser netperf
@@ -21,13 +28,6 @@ pkg_setup() {
}
src_prepare() {
- eapply \
- "${FILESDIR}"/${PN}-fix-scripts.patch \
- "${FILESDIR}"/${PN}-2.6.0-log-dir.patch \
- "${FILESDIR}"/${PN}-2.7.0-includes.patch \
- "${FILESDIR}"/${PN}-2.7.0-space.patch \
- "${FILESDIR}"/${PN}-2.7.0-inline.patch
-
# Fixing paths in scripts
sed -i \
-e 's:^\(NETHOME=\).*:\1"/usr/bin":' \
@@ -39,7 +39,7 @@ src_prepare() {
doc/examples/udp_stream_script \
|| die
- eapply_user
+ default
}
src_configure() {
@@ -57,10 +57,10 @@ src_configure() {
src_install() {
default
- # move netserver into sbin as we had it before 2.4 was released with its
+ # Move netserver into sbin as we had it before 2.4 was released with its
# autoconf goodness
dodir /usr/sbin
- mv "${D}"/usr/{bin,sbin}/netserver || die
+ mv "${ED}"/usr/{bin,sbin}/netserver || die
# init.d / conf.d
newinitd "${FILESDIR}"/${PN}-2.7.0-init netperf
@@ -73,6 +73,6 @@ src_install() {
# documentation and example scripts
dodoc AUTHORS ChangeLog NEWS README Release_Notes
dodir /usr/share/doc/${PF}/examples
- #Scripts no longer get installed by einstall
- cp doc/examples/*_script "${D}"/usr/share/doc/${PF}/examples || die
+ # Scripts no longer get installed by einstall
+ cp doc/examples/*_script "${ED}"/usr/share/doc/${PF}/examples || die
}