summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-02-07 04:50:12 +0300
committerPatrice Clement <monsieurp@gentoo.org>2019-03-13 15:58:27 +0100
commitbdb9f0c42f339d8752d912f99c145e4d5d7643b9 (patch)
tree206606274c255d03de8b132c26c60850f1fc8c49 /net-analyzer/openvas-libraries/files/openvas-libraries-9.0.3-rundir.patch
parentnet-analyzer/openvas: version bump to 9.0.0. (diff)
downloadgentoo-bdb9f0c42f339d8752d912f99c145e4d5d7643b9.tar.gz
gentoo-bdb9f0c42f339d8752d912f99c145e4d5d7643b9.tar.bz2
gentoo-bdb9f0c42f339d8752d912f99c145e4d5d7643b9.zip
net-analyzer/openvas-libraries: version bump to 9.0.3.
Bump to 9.0.3. This also fixes cmake bug 663446 and introduces the new USE flags 'extras' 'ldap' 'radius'. Introduces six new patches which fixes build and QA issues: - gcc8.patch fixes gcc-8 build issue. - netsnmp.patch fixes cmake netsnmp name issue. - cachedir.patch fixes unnecessary directory install QA issue. - rundir.patch fixes unnecessary directory install QA issue. - rpath.patch fixes insecure rpath QA issue. - underlinking.patch fixes linking issue. Because of new dependencies ~arm ~ppc keywords have been dropped. This package is part of net-analyzer/openvas. Reported-by: Toralf Förster <toralf@gentoo.org> Reported-by: NP-Hardass <np-hardass@gentoo.org> Acked-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Closes: https://bugs.gentoo.org/663446 Tested-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-analyzer/openvas-libraries/files/openvas-libraries-9.0.3-rundir.patch')
-rw-r--r--net-analyzer/openvas-libraries/files/openvas-libraries-9.0.3-rundir.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-analyzer/openvas-libraries/files/openvas-libraries-9.0.3-rundir.patch b/net-analyzer/openvas-libraries/files/openvas-libraries-9.0.3-rundir.patch
new file mode 100644
index 000000000000..6ecdc8a64219
--- /dev/null
+++ b/net-analyzer/openvas-libraries/files/openvas-libraries-9.0.3-rundir.patch
@@ -0,0 +1,45 @@
+--- gvm-libs-9.0.3/CMakeLists.txt 2019-02-04 14:50:41.230530261 +0300
++++ gvm-libs-9.0.3/CMakeLists.txt 2019-02-04 14:55:08.649433070 +0300
+@@ -162,9 +162,9 @@
+ set (DATADIR "${CMAKE_INSTALL_PREFIX}/share")
+ endif (NOT DATADIR)
+
+-if (NOT OPENVAS_PID_DIR)
+- set (OPENVAS_PID_DIR "${LOCALSTATEDIR}/run")
+-endif (NOT OPENVAS_PID_DIR)
++#if (NOT OPENVAS_PID_DIR)
++# set (OPENVAS_PID_DIR "${LOCALSTATEDIR}/run")
++#endif (NOT OPENVAS_PID_DIR)
+
+ #if (NOT SYSCONFDIR)
+ # set (SYSCONFDIR "${CMAKE_INSTALL_PREFIX}/etc")
+--- gvm-libs-9.0.3/base/pidfile.c 2018-08-29 19:01:12.000000000 +0300
++++ gvm-libs-9.0.3/base/pidfile.c 2019-02-04 15:08:04.600958560 +0300
+@@ -59,7 +59,7 @@
+ pidfile_create (gchar * daemon_name)
+ {
+ gchar *name_pid = g_strconcat (daemon_name, ".pid", NULL);
+- gchar *pidfile_name = g_build_filename (OPENVAS_PID_DIR, name_pid, NULL);
++ gchar *pidfile_name = g_build_filename (name_pid, NULL);
+ FILE *pidfile = g_fopen (pidfile_name, "w");
+
+ g_free (name_pid);
+@@ -88,7 +88,7 @@
+ pidfile_remove (gchar * daemon_name)
+ {
+ gchar *name_pid = g_strconcat (daemon_name, ".pid", NULL);
+- gchar *pidfile_name = g_build_filename (OPENVAS_PID_DIR, name_pid, NULL);
++ gchar *pidfile_name = g_build_filename (name_pid, NULL);
+ gchar *pidfile_contents;
+
+ g_free (name_pid);
+--- gvm-libs-9.0.3/CMakeLists.txt 2019-02-04 17:39:39.776282496 +0300
++++ gvm-libs-9.0.3/CMakeLists.txt 2019-02-04 17:39:23.160269081 +0300
+@@ -329,7 +329,6 @@
+
+ install (DIRECTORY DESTINATION ${OPENVAS_LOG_DIR})
+ install (DIRECTORY DESTINATION ${OPENVAS_DATA_DIR})
+-install (DIRECTORY DESTINATION ${OPENVAS_PID_DIR})
+ install (DIRECTORY DESTINATION ${OPENVAS_SYSCONF_DIR})
+ install (DIRECTORY
+ DESTINATION ${OPENVAS_SYSCONF_DIR}/gnupg