summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-24 13:43:09 +0100
committerJeroen Roovers <jer@gentoo.org>2018-03-24 13:44:24 +0100
commit5d6f6c6b6aade8275782d989c18cce074a12066c (patch)
tree3fdb7020dafed0f9217f74e025ac0523a839b9d7 /net-analyzer/rrdtool
parentnet-misc/dropbear: stable 2017.75 for hppa, bug #619002 (diff)
downloadgentoo-5d6f6c6b6aade8275782d989c18cce074a12066c.tar.gz
gentoo-5d6f6c6b6aade8275782d989c18cce074a12066c.tar.bz2
gentoo-5d6f6c6b6aade8275782d989c18cce074a12066c.zip
net-analyzer/rrdtool: Use HTTPS.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/rrdtool')
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.6.0-r1.ebuild9
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.7.0.ebuild11
2 files changed, 11 insertions, 9 deletions
diff --git a/net-analyzer/rrdtool/rrdtool-1.6.0-r1.ebuild b/net-analyzer/rrdtool/rrdtool-1.6.0-r1.ebuild
index 9d61df1ee9a9..b6a50b536199 100644
--- a/net-analyzer/rrdtool/rrdtool-1.6.0-r1.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.6.0-r1.ebuild
@@ -9,9 +9,11 @@ GENTOO_DEPEND_ON_PERL=no
PYTHON_COMPAT=( python2_7 )
inherit autotools eutils perl-module distutils-r1 flag-o-matic multilib
+MY_P=${P/_/-}
+
DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
-SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P/_/-}.tar.gz"
+HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
+SRC_URI="${HOMEPAGE}pub/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/8.0.0"
@@ -48,8 +50,7 @@ RDEPEND="
PDEPEND="
ruby? ( ~dev-ruby/rrdtool-bindings-${PV} )
"
-
-S=${WORKDIR}/${P/_/-}
+S=${WORKDIR}/${MY_P}
python_compile() {
cd bindings/python || die
diff --git a/net-analyzer/rrdtool/rrdtool-1.7.0.ebuild b/net-analyzer/rrdtool/rrdtool-1.7.0.ebuild
index 88256ecc9dc2..955b659434e5 100644
--- a/net-analyzer/rrdtool/rrdtool-1.7.0.ebuild
+++ b/net-analyzer/rrdtool/rrdtool-1.7.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,9 +9,11 @@ GENTOO_DEPEND_ON_PERL=no
PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit autotools perl-module distutils-r1 flag-o-matic multilib
+MY_P=${P/_/-}
+
DESCRIPTION="A system to store and display time-series data"
-HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
-SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P/_/-}.tar.gz"
+HOMEPAGE="https://oss.oetiker.ch/rrdtool/"
+SRC_URI="${HOMEPAGE}pub/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0/8.0.0"
@@ -55,8 +57,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.7.0-disable-rrd_graph-cgi.patch
)
-
-S=${WORKDIR}/${P/_/-}
+S=${WORKDIR}/${MY_P}
python_compile() {
cd bindings/python || die