summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2022-11-30 20:22:07 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-12-01 08:45:32 +0100
commit5e9c2dc89661b7753551be27e739eceda7e3d24f (patch)
tree70b74f4e6845dfa14d9877dd6cece2addd9ec929 /net-analyzer/wtfis
parentapp-backup/dar: add 2.7.8 (diff)
downloadgentoo-5e9c2dc89661b7753551be27e739eceda7e3d24f.tar.gz
gentoo-5e9c2dc89661b7753551be27e739eceda7e3d24f.tar.bz2
gentoo-5e9c2dc89661b7753551be27e739eceda7e3d24f.zip
net-analyzer/wtfis: add 0.5.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/28483 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer/wtfis')
-rw-r--r--net-analyzer/wtfis/Manifest1
-rw-r--r--net-analyzer/wtfis/wtfis-0.5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
index da10d284853e..d1f9de55cb9d 100644
--- a/net-analyzer/wtfis/Manifest
+++ b/net-analyzer/wtfis/Manifest
@@ -1 +1,2 @@
DIST wtfis-0.4.0.gh.tar.gz 459363 BLAKE2B 10338f17700815aa8f25bd1e9587855795710925481ea3d7bd85782fea657055053d965977f601bc25d624352c97c639008d33d30aa3ac248ea7504c7e0ceaa7 SHA512 bb19923668e8172fd07b86159839c95a1b32d9975edcf1e9ab99bb574eae24f70c3a6bf83cc8ade66c1e5f57632625e7f604966ee06445839df87a9af4962573
+DIST wtfis-0.5.0.gh.tar.gz 461913 BLAKE2B 57be019cda4d67943b0c1b2f99013b34351d2ded036f76939f94221218554b5c3fe8711da85f40fcd0fdfbb57df5713b4a72cd09a6b665b5893ffdb8efca493f SHA512 5717ea43d63843f2b6d1e70afac12a70790284a1ed9bdae31c0ee062f77b718e19e913cfefb30cb3bdebf2f925da153354aa906349de97707ac739f736fc94ad
diff --git a/net-analyzer/wtfis/wtfis-0.5.0.ebuild b/net-analyzer/wtfis/wtfis-0.5.0.ebuild
new file mode 100644
index 000000000000..06c4fc422fe5
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~loong ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-1.10.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.28.1[${PYTHON_USEDEP}]
+ >=dev-python/rich-12.6.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.28.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest