summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2024-02-21 22:37:29 +0100
committerFlorian Schmaus <flow@gentoo.org>2024-03-17 14:52:36 +0100
commit7ad93d3f4e140be4513906a8cfed7444cba30086 (patch)
tree055cb684ca10a8361f444c7a07eff05aa891f9b9 /net-analyzer
parentnet-analyzer/wtfis: enable py3.12 (diff)
downloadgentoo-7ad93d3f4e140be4513906a8cfed7444cba30086.tar.gz
gentoo-7ad93d3f4e140be4513906a8cfed7444cba30086.tar.bz2
gentoo-7ad93d3f4e140be4513906a8cfed7444cba30086.zip
net-analyzer/wtfis: add 0.8.0
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/35477 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wtfis/Manifest1
-rw-r--r--net-analyzer/wtfis/wtfis-0.8.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-analyzer/wtfis/Manifest b/net-analyzer/wtfis/Manifest
index be735c0292bc..2f306e359f37 100644
--- a/net-analyzer/wtfis/Manifest
+++ b/net-analyzer/wtfis/Manifest
@@ -1 +1,2 @@
DIST wtfis-0.7.1.gh.tar.gz 548395 BLAKE2B fbcc19358a0a357fdc9f4b5f27d4bda60e20a118c3c3b7cdfd90fad956d2ef0375efe4f0c8a3a94bfa8a6657d5bb710eaacb403b8c3d446921b963e3e8909442 SHA512 9a77c17e1e922e6d17aba9c6cc7364c8b65bc401cbca311280a4eef958056238aef87c2a8891c1bce5848083d1a7e5e00b0b63ead5ffefdea80ae7baee40c845
+DIST wtfis-0.8.0.gh.tar.gz 576810 BLAKE2B ac4573893aacc2533fe9ed3248613d3bf5ffb390a2dcbf01fd0590093a7bf753ee8da6e67b60142111726d55928a7913bb3f7ae1a22474876dec1cb3d81d3a3c SHA512 b709948d0ccd75472d9ccc0bfc4cec943700e57eccc42cc486075b8b89516fff054b6df92d6b23999987bab97b80db755de575cba4b56e2bd01a6bf24f058798
diff --git a/net-analyzer/wtfis/wtfis-0.8.0.ebuild b/net-analyzer/wtfis/wtfis-0.8.0.ebuild
new file mode 100644
index 000000000000..002d2b6053e0
--- /dev/null
+++ b/net-analyzer/wtfis/wtfis-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+DESCRIPTION="Passive hostname, domain and IP lookup tool for non-robots"
+HOMEPAGE="https://github.com/pirxthepilot/wtfis"
+
+if [[ ${PV} = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/pirxthepilot/wtfis.git"
+else
+ SRC_URI="https://github.com/pirxthepilot/wtfis/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~loong ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pydantic-2.0.3[${PYTHON_USEDEP}]
+ >=dev-python/python-dotenv-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.31.0[${PYTHON_USEDEP}]
+ >=dev-python/rich-13.4.2[${PYTHON_USEDEP}]
+ <dev-python/rich-13.5.0[${PYTHON_USEDEP}]
+ >=net-analyzer/shodan-1.29.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest