summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-04-15 12:01:05 +0200
committerJeroen Roovers <jer@gentoo.org>2019-04-15 12:02:35 +0200
commit41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98 (patch)
treee57f7918a5663613b341721dd1cfdf697c3e7f88 /net-libs/libprotoident/libprotoident-2.0.13.ebuild
parentnet-analyzer/bwping: Use HTTPS (diff)
downloadgentoo-41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98.tar.gz
gentoo-41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98.tar.bz2
gentoo-41b8b24cdbb2ce84fb60e262b4bfd843f1f0ca98.zip
net-libs/libprotoident: Version 2.0.13
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-libs/libprotoident/libprotoident-2.0.13.ebuild')
-rw-r--r--net-libs/libprotoident/libprotoident-2.0.13.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libprotoident/libprotoident-2.0.13.ebuild b/net-libs/libprotoident/libprotoident-2.0.13.ebuild
new file mode 100644
index 000000000000..8d80ce7cabdc
--- /dev/null
+++ b/net-libs/libprotoident/libprotoident-2.0.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A library that performs application layer protocol identification for flows"
+HOMEPAGE="https://research.wand.net.nz/software/libprotoident.php"
+SRC_URI="https://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs tools"
+
+DEPEND="
+ >=net-libs/libtrace-4.0.1
+ >=net-libs/libflowmanager-3.0.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-Werror/d' \
+ lib/Makefile{.am,.in} || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with tools)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}