summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-12-21 05:03:51 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-12-21 05:07:48 +1100
commitccff46f20332325b8b9aaaff445039f9000767d9 (patch)
tree99a8292b975f71493787bd2646be08e2a0f6ed81 /net-libs/libsignon-glib
parentsys-devel/flex: disable building tests when USE=-test #568842 (diff)
downloadgentoo-ccff46f20332325b8b9aaaff445039f9000767d9.tar.gz
gentoo-ccff46f20332325b8b9aaaff445039f9000767d9.tar.bz2
gentoo-ccff46f20332325b8b9aaaff445039f9000767d9.zip
net-libs/libsignon-glib: version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-libs/libsignon-glib')
-rw-r--r--net-libs/libsignon-glib/Manifest1
-rw-r--r--net-libs/libsignon-glib/libsignon-glib-1.13.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/net-libs/libsignon-glib/Manifest b/net-libs/libsignon-glib/Manifest
index 48c9856f6ca9..ef6cea77fdaf 100644
--- a/net-libs/libsignon-glib/Manifest
+++ b/net-libs/libsignon-glib/Manifest
@@ -1 +1,2 @@
DIST libsignon-glib-1.12.tar.xz 42384 SHA256 bd7e3be291e3173f20dda5376e1387be5d1705b12a00885e93f2cc900a9b4463 SHA512 5d5a3918898dce9d8b10597ac95428bef4753a1c626b6e7fef54e9024327b0849ddb628b25801504c336cf6fe2ebc16e5264bb576ecab16457ccf17918f042cf WHIRLPOOL 5766ad1fe50a6637d2f8e5fe6b092599112c9b6fb56dd44502568d41d61d3208d8d5a00ce1c698848f3fbeb0eb0a1ee82bcbebaff74428a97f634589e56d9def
+DIST libsignon-glib-1.13.tar.gz 51601 SHA256 8e0e450e719c16f79d3c3aadb98656ed5967a2f2cd24c1d9cd5747e670a087bc SHA512 aaae6a37a113685eb36ddccd497e387617cf0900506638cbafbac282c4d63ade41f4c915ad6f04214c58af580b70d9062ecf3e1618b6f5fe07dad50c5dc125a6 WHIRLPOOL 8f0d1d51588e42c9fac51883a9ecb08b6ad4949fc8f335c2259f967ea8f3555b04b3ca46f323b20591a2bc85dc1b5bba3968fec1be3e4dfd7a9464e2c5d6880e
diff --git a/net-libs/libsignon-glib/libsignon-glib-1.13.ebuild b/net-libs/libsignon-glib/libsignon-glib-1.13.ebuild
new file mode 100644
index 000000000000..36b0e0b0d693
--- /dev/null
+++ b/net-libs/libsignon-glib/libsignon-glib-1.13.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit autotools python-r1 vcs-snapshot
+
+DESCRIPTION="GLib binding for the D-Bus API provided by signond"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libsignon-glib/repository/archive.tar.gz?ref=VERSION_1.13 -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc python test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ dev-libs/glib:2
+ net-libs/signond
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ python? ( ${PYTHON_DEPS} )
+ doc? ( dev-util/gtk-doc )
+"
+
+DOCS=( AUTHORS NEWS README )
+
+# needs more love
+RESTRICT="test"
+
+src_prepare() {
+ if ! use doc; then
+ epatch "${FILESDIR}/${PN}-1.12-doc-disable.patch"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ myconfigure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable doc gtk-doc)
+ $(use_enable python)
+ $(use_enable test tests)
+ )
+
+ econf "${myeconfargs[@]}"
+ }
+
+ if use python; then
+ python_copy_sources
+ python_foreach_impl run_in_build_dir myconfigure
+ else
+ myconfigure
+ fi
+}
+
+src_compile() {
+ # fails to compile with more than one thread
+ MAKEOPTS="${MAKEOPTS} -j1"
+ default
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ fi
+}
+
+src_install() {
+ default
+ if use python; then
+ python_foreach_impl run_in_build_dir default
+ fi
+}