summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosiah Mullins <JoMull01@protonmail.com>2022-06-15 17:32:01 -0400
committerSam James <sam@gentoo.org>2022-06-16 17:31:51 +0100
commit92da724cf53e4d47af529b84c6e65a0207dd2dad (patch)
tree0e6c137e969d7f2e75d3a56b7ce10a5e2759b4a4 /net-libs
parentnet-libs/tox: Removed old version 0.2.12-r1 (diff)
downloadgentoo-92da724cf53e4d47af529b84c6e65a0207dd2dad.tar.gz
gentoo-92da724cf53e4d47af529b84c6e65a0207dd2dad.tar.bz2
gentoo-92da724cf53e4d47af529b84c6e65a0207dd2dad.zip
net-libs/tox: Bump to version 0.2.18
This commit also introduces the use flag key-utils. This enables additional utilities to be build that allow brute force key searches to find keys that start with a specific string. The utilities also allow for profiles to be generated from multiple input data. Signed-off-by: Josiah Mullins <JoMull01@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/tox/Manifest1
-rw-r--r--net-libs/tox/metadata.xml1
-rw-r--r--net-libs/tox/tox-0.2.18.ebuild (renamed from net-libs/tox/tox-9999.ebuild)63
3 files changed, 40 insertions, 25 deletions
diff --git a/net-libs/tox/Manifest b/net-libs/tox/Manifest
index f4ae35a1a3fd..2fc1f7467d21 100644
--- a/net-libs/tox/Manifest
+++ b/net-libs/tox/Manifest
@@ -1 +1,2 @@
DIST c-toxcore-0.2.13.tar.gz 511533 BLAKE2B 8c68180710e3d06eaaef9fc05dc0ff2492907586934d1d6f57f147e07bb78b262f78b0057911e4b5cd27d2d1efb51cb714f757b90caa269988e604cafa62cd00 SHA512 f4ed9ea4afb7f9c14a5afd949f3a52e7880838c910acaf5adc39acb09ad574406be08f43b76a9fbdd4fc4bd14f0d73212dc7bd10783565055c910c6c3e5e357a
+DIST c-toxcore-0.2.18.tar.gz 653247 BLAKE2B c27da02753aede5056c42e5bf1949920fc30e98a23c058ab445c2fe345271e442885a3eeb011e8fde16d8fc8451376a015c5f821145785c75e7d0dda3a8b72eb SHA512 e9b0d73a2e0460290c8453a0a64fc91deed2e0cf87f945d0ba203b929f19a296571d7140f4df89b06f7e67f2b61894460ce4dd32ab9ecf6ea7d5b67538fadb23
diff --git a/net-libs/tox/metadata.xml b/net-libs/tox/metadata.xml
index fa963f9331e6..434e886648f5 100644
--- a/net-libs/tox/metadata.xml
+++ b/net-libs/tox/metadata.xml
@@ -12,6 +12,7 @@
<use>
<flag name="av">Adds support for audio and video.</flag>
<flag name="dht-node">Enables DHT Bootstrap Node.</flag>
+ <flag name="key-utils">Builds utilities to create custom keys and profiles</flag>
<flag name="log-error">Log level: 1</flag>
<flag name="log-warn">Log level: 2</flag>
<flag name="log-info">Log level: 3</flag>
diff --git a/net-libs/tox/tox-9999.ebuild b/net-libs/tox/tox-0.2.18.ebuild
index ba31cc1a5c28..19cb445abe6f 100644
--- a/net-libs/tox/tox-9999.ebuild
+++ b/net-libs/tox/tox-0.2.18.ebuild
@@ -1,44 +1,47 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake git-r3 systemd
+inherit cmake systemd
DESCRIPTION="Encrypted P2P, messaging, and audio/video calling platform"
-HOMEPAGE="https://tox.chat"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/TokTok/c-toxcore.git"
+HOMEPAGE="https://tox.chat https://github.com/TokTok/c-toxcore"
+SRC_URI="https://github.com/TokTok/c-toxcore/releases/download/v${PV}/c-toxcore-${PV}.tar.gz"
LICENSE="GPL-3+"
SLOT="0/0.2"
-KEYWORDS=""
-IUSE="+av daemon dht-node ipv6 log-debug +log-error log-info log-trace log-warn test"
-RESTRICT="!test? ( test )"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="+av debug daemon dht-node ipv6 key-utils log-debug +log-error log-info log-trace log-warn test"
REQUIRED_USE="?? ( log-debug log-error log-info log-trace log-warn )
daemon? ( dht-node )"
+RESTRICT="!test? ( test )"
BDEPEND="virtual/pkgconfig"
DEPEND="dev-libs/libsodium:=[asm,urandom,-minimal]
+ dev-libs/msgpack
av? (
media-libs/libvpx:=
media-libs/opus
)
daemon? ( dev-libs/libconfig:= )"
-RDEPEND="
- ${DEPEND}
+
+RDEPEND="${DEPEND}
daemon? (
acct-group/tox
acct-user/tox
- )"
+ )
+ key-utils? ( || ( sys-devel/gcc[openmp] sys-devel/clang-runtime[openmp] ) )"
+
+S="${WORKDIR}/${MY_P}"
src_prepare() {
cmake_src_prepare
- #remove faulty tests
- for testname in lan_discovery save_compatibility set_status_message; do
- sed -i -e "/^auto_test(${testname})$/d" CMakeLists.txt || die
+ #Remove faulty tests
+ for testname in lan_discovery save_load; do
+ sed -i -e "/^auto_test(${testname})$/d" ./auto_tests/CMakeLists.txt || die
done
}
@@ -46,16 +49,24 @@ src_configure() {
local mycmakeargs=(
-DAUTOTEST=$(usex test ON OFF)
-DBOOTSTRAP_DAEMON=$(usex daemon ON OFF)
+ -DBUILD_FUN_UTILS=$(usex key-utils ON OFF)
+ -DBUILD_FUZZ_TESTS=OFF #Upstream reports that this breaks all other tests
-DBUILD_MISC_TESTS=$(usex test ON OFF)
-DBUILD_TOXAV=$(usex av ON OFF)
+ -DCMAKE_BUILD_TYPE=$(usex debug Debug Release)
-DDHT_BOOTSTRAP=$(usex dht-node ON OFF)
-DENABLE_SHARED=ON
-DENABLE_STATIC=OFF
- -DMUST_BUILD_TOXAV=$(usex av ON OFF))
+ -DFULLY_STATIC=OFF
+ -DMUST_BUILD_TOXAV=$(usex av ON OFF)
+ )
+
if use test; then
mycmakeargs+=(
- -DTEST_TIMEOUT_SECONDS=120
- -DUSE_IPV6=$(usex ipv6 ON OFF))
+ -DTEST_TIMEOUT_SECONDS=150
+ -DNON_HERMETIC_TESTS=OFF
+ -DUSE_IPV6=$(usex ipv6 ON OFF)
+ )
else
mycmakeargs+=(-DUSE_IPV6=OFF)
fi
@@ -72,8 +83,9 @@ src_configure() {
mycmakeargs+=(-DMIN_LOGGER_LEVEL="ERROR")
else
mycmakeargs+=(-DMIN_LOGGER_LEVEL="")
- einfo "Logging Disabled"
+ einfo "Logging disabled"
fi
+
cmake_src_configure
}
@@ -95,12 +107,13 @@ src_install() {
pkg_postinst() {
if use dht-node; then
- ewarn "There is currently an unresolved issuer with tox DHT"
- ewarn "Bootstrap node that causes the program to be built"
- ewarn "with a null libray reference. This causes an infinite"
- ewarn "loop for certain revdep-rebuild commands. If you aren't"
- ewarn "running a node, please consider disabling the dht node"
- ewarn "use flag. For more information please refer to"
- ewarn "https://github.com/toktok/c-toxcore/issues/1144"
+ ewarn "The QA notice regarding libmisc_tools.so is known by the upstream"
+ ewarn "developers and is on their TODO list. For more information,"
+ ewarn "please see 'https://github.com/toktok/c-toxcore/issues/1144'"
+ ewarn ""
+ ewarn "There is currently an unresolved issue with tox DHT Bootstrap node"
+ ewarn "that causes the program to be built with a null library reference."
+ ewarn "This causes an infinite loop for certain revdep-rebuild commands."
+ ewarn "If you aren't running a node, please consider disabling the dht-node use flag."
fi
}