summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-06 10:37:47 +0000
committerSam James <sam@gentoo.org>2024-11-06 10:46:52 +0000
commitc968a52d1ea7b75b4f11c1752cb65a7957089482 (patch)
tree6ff972b6f846dc21a07535feabc8e3b291dc0258 /net-libs
parentnet-misc/nyx: fix Python 3.11 compat (diff)
downloadgentoo-c968a52d1ea7b75b4f11c1752cb65a7957089482.tar.gz
gentoo-c968a52d1ea7b75b4f11c1752cb65a7957089482.tar.bz2
gentoo-c968a52d1ea7b75b4f11c1752cb65a7957089482.zip
net-libs/stem: drop 1.8.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/stem/Manifest1
-rw-r--r--net-libs/stem/files/1.8.0-replace-all-usages-of-inspect.getargspec.patch53
-rw-r--r--net-libs/stem/stem-1.8.1.ebuild50
3 files changed, 0 insertions, 104 deletions
diff --git a/net-libs/stem/Manifest b/net-libs/stem/Manifest
index 8e45a8395e6e..cff536f1e6be 100644
--- a/net-libs/stem/Manifest
+++ b/net-libs/stem/Manifest
@@ -1,2 +1 @@
-DIST stem-1.8.1.tar.gz 2859634 BLAKE2B f78da079791583a17eb439a4e2459c7e0af454e45300202df1085d1b1ba150ee097cfa1b93df5ad0d7090644fad6e035604382c73b94744076cad490ab52459a SHA512 bad2f4f96e37caa3ee2928bb027318c4941ca3f6c0072c5f6e87fe647d2b68400ad352d9c27fa2a35c00f4f327aa9cc00e2907b21a9cbd26fab46ec21e2a038a
DIST stem-1.8.2.tar.gz 2859640 BLAKE2B 4539fc42a463cd1c2ebba10bb31a69d529c41cdaee623beebd3219a2c1d59f8f9b8242b537dd4244e666fb765c5af2729caeeb22a7f8cd1ca6c13dd3cf6aac93 SHA512 f054bbc9a61e04fb7e3b7d1534803b938b855c29795471953661f8fd9c0a5196fe1f9ccfd01e5b3256ea42893a7d57fda34fa54932012e345f74bb3303ff98c5
diff --git a/net-libs/stem/files/1.8.0-replace-all-usages-of-inspect.getargspec.patch b/net-libs/stem/files/1.8.0-replace-all-usages-of-inspect.getargspec.patch
deleted file mode 100644
index 608fe5f5224f..000000000000
--- a/net-libs/stem/files/1.8.0-replace-all-usages-of-inspect.getargspec.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 6497514ea89ba44d404b661d495a8cd2649ac628 Mon Sep 17 00:00:00 2001
-From: Juan Orti Alcaine <jortialc@redhat.com>
-Date: Fri, 1 Jul 2022 09:40:41 +0200
-Subject: [PATCH] Replace all usages of inspect.getargspec
-
----
- stem/control.py | 2 +-
- stem/prereq.py | 2 +-
- stem/util/conf.py | 2 +-
- 3 files changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/stem/control.py b/stem/control.py
-index 42736486..3b29898d 100644
---- a/stem/control.py
-+++ b/stem/control.py
-@@ -474,7 +474,7 @@ def with_default(yields = False):
-
- def decorator(func):
- def get_default(func, args, kwargs):
-- arg_names = inspect.getargspec(func).args[1:] # drop 'self'
-+ arg_names = inspect.getfullargspec(func).args[1:] # drop 'self'
- default_position = arg_names.index('default') if 'default' in arg_names else None
-
- if default_position is not None and default_position < len(args):
-diff --git a/stem/prereq.py b/stem/prereq.py
-index 4af6c093..4009c317 100644
---- a/stem/prereq.py
-+++ b/stem/prereq.py
-@@ -241,7 +241,7 @@ def is_mock_available():
-
- # check for mock's new_callable argument for patch() which was introduced in version 0.8.0
-
-- if 'new_callable' not in inspect.getargspec(mock.patch).args:
-+ if 'new_callable' not in inspect.getfullargspec(mock.patch).args:
- raise ImportError()
-
- return True
-diff --git a/stem/util/conf.py b/stem/util/conf.py
-index 80399810..15c4db8b 100644
---- a/stem/util/conf.py
-+++ b/stem/util/conf.py
-@@ -285,7 +285,7 @@ def uses_settings(handle, path, lazy_load = True):
- config.load(path)
- config._settings_loaded = True
-
-- if 'config' in inspect.getargspec(func).args:
-+ if 'config' in inspect.getfullargspec(func).args:
- return func(*args, config = config, **kwargs)
- else:
- return func(*args, **kwargs)
---
-2.36.1
-
diff --git a/net-libs/stem/stem-1.8.1.ebuild b/net-libs/stem/stem-1.8.1.ebuild
deleted file mode 100644
index 6cd30508aeaa..000000000000
--- a/net-libs/stem/stem-1.8.1.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Stem is a Python controller library for Tor"
-HOMEPAGE="https://stem.torproject.org"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~riscv ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-DEPEND="test? ( dev-python/pyflakes[${PYTHON_USEDEP}]
- net-vpn/tor )"
-
-RDEPEND="net-vpn/tor"
-
-DOCS=( docs/{_static,_templates,api,tutorials,{api,change_log,contents,download,faq,index,tutorials}.rst} )
-
-src_prepare() {
- default
-
- # https://bugzilla.redhat.com/2021902
- eapply "${FILESDIR}/1.8.0-replace-all-usages-of-inspect.getargspec.patch"
-
- # https://github.com/torproject/stem/issues/53
- eapply "${FILESDIR}/${PV}-Add-an-exclude-test-argument.patch"
-
- # https://github.com/torproject/stem/issues/56
- sed -i '/MOCK_VERSION/d' run_tests.py || die
-}
-
-python_test() {
- # Disable failing test
- ${PYTHON} run_tests.py --all --target RUN_ALL \
- --exclude-test test.integ.installation.TestInstallation.test_install \
- --exclude-test test.integ.util.system.TestSystem.test_expand_path \
- --exclude-test test.integ.control.controller.TestController.test_get_listeners \
- --exclude-test test.integ.control.controller.TestController.test_get_ports \
- --exclude-test test.integ.control.controller.TestController.test_getinfo_freshrelaydescs \
- || die
-
-}