summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-02-21 17:41:20 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 13:13:25 +0100
commitd636318073653f4d25d3680f7ae5a56a22500c44 (patch)
tree018d05f3db81ed95d640399e2308b52b758b7d73 /net-libs
parentnet-libs/libsrsirc: EAPI8 bump (diff)
downloadgentoo-d636318073653f4d25d3680f7ae5a56a22500c44.tar.gz
gentoo-d636318073653f4d25d3680f7ae5a56a22500c44.tar.bz2
gentoo-d636318073653f4d25d3680f7ae5a56a22500c44.zip
net-libs/libpri: EAPI8 bump, use https
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/35471 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libpri/libpri-1.6.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/libpri/libpri-1.6.0-r1.ebuild b/net-libs/libpri/libpri-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..f32cac3d821e
--- /dev/null
+++ b/net-libs/libpri/libpri-1.6.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="Primary Rate ISDN (PRI) library"
+HOMEPAGE="https://www.asterisk.org/"
+SRC_URI="https://downloads.asterisk.org/pub/telephony/${PN}/releases/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.13-multilib.patch"
+ "${FILESDIR}/${PN}-1.6.0-respect-user-flags.patch"
+ "${FILESDIR}/${PN}-1.4.13-no-static-lib.patch"
+)
+
+src_compile() {
+ tc-export CC
+ default
+}
+src_install() {
+ emake INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install
+ dodoc ChangeLog README TODO
+}