summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-01-02 22:54:36 +0100
committerMichael Weber <xmw@gentoo.org>2016-01-02 22:56:00 +0100
commitd1c3e6fc1e9755539c8e9adb23260972273b5438 (patch)
tree21cefb12c80dcfb3ae66e9ecadfc3e6e3a2c7eb4 /net-misc/clipgrab/clipgrab-3.5.6.ebuild
parentmedia-plugins/gst-plugins-pulse: add missing gst-plugins-base dependency, bug... (diff)
downloadgentoo-d1c3e6fc1e9755539c8e9adb23260972273b5438.tar.gz
gentoo-d1c3e6fc1e9755539c8e9adb23260972273b5438.tar.bz2
gentoo-d1c3e6fc1e9755539c8e9adb23260972273b5438.zip
net-misc/clipgrab: Version bump (thanks Sergey S. Starikoff, bug 568662).
Package-Manager: portage-2.2.26
Diffstat (limited to 'net-misc/clipgrab/clipgrab-3.5.6.ebuild')
-rw-r--r--net-misc/clipgrab/clipgrab-3.5.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-misc/clipgrab/clipgrab-3.5.6.ebuild b/net-misc/clipgrab/clipgrab-3.5.6.ebuild
new file mode 100644
index 000000000000..fbb2e97fa0ea
--- /dev/null
+++ b/net-misc/clipgrab/clipgrab-3.5.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-r2 eutils
+
+DESCRIPTION="Download from various internet video services like Youtube etc."
+HOMEPAGE="http://clipgrab.de/en"
+SRC_URI="http://download.${PN}.de/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-qt/qtwebkit:4"
+RDEPEND="${DEPEND}
+ || ( media-video/libav media-video/ffmpeg )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.4.2-obey.patch"
+)
+
+src_install() {
+ dobin ${PN}
+
+ newicon icon.png ${PN}.png
+ make_desktop_entry clipgrab Clipgrab "" "Qt;Video;AudioVideo;"
+}