summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-02-15 10:56:49 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-16 10:40:31 +0200
commit4a2919fee552be18843e10596fa21743263bcb5d (patch)
tree6e737c073242e1a776b6e23833051cfca40b0fb5 /net-misc/gnome-connections
parentmedia-gfx/shotwell: update HOMEPAGE (diff)
downloadgentoo-4a2919fee552be18843e10596fa21743263bcb5d.tar.gz
gentoo-4a2919fee552be18843e10596fa21743263bcb5d.tar.bz2
gentoo-4a2919fee552be18843e10596fa21743263bcb5d.zip
net-misc/gnome-connections: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/35347 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-misc/gnome-connections')
-rw-r--r--net-misc/gnome-connections/Manifest1
-rw-r--r--net-misc/gnome-connections/gnome-connections-46.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/gnome-connections/Manifest b/net-misc/gnome-connections/Manifest
index a6090987ecdf..d5d5f9a9762a 100644
--- a/net-misc/gnome-connections/Manifest
+++ b/net-misc/gnome-connections/Manifest
@@ -1 +1,2 @@
DIST gnome-connections-45.0.tar.xz 4009108 BLAKE2B 10f3f98df6fd6a090c226192229c3eeba7d707c1a109eaaf3a6427b9eadd375a136da9f089b904b66d9e94f27b9b6f982f1c0392ac9eb00936f46450b48bfbf6 SHA512 a2c5f8cd3076fc370cdd34f909bd02d07b9391a606133a46d17a5fd92644ee971c7dddb09674d660a462b9f0d99e83ef2b595095173274e54bbdc0f8411fffe4
+DIST gnome-connections-46.0.tar.xz 4036956 BLAKE2B f7f797353c57d615761b3048d5b2f50f21a6dd3245de9ab201317da10116f807cb9b301aec660165206ec61de42b4328debf5190e5d97e4c9e550af6edefe45a SHA512 7c57d2aa581abc6862f2509ed530d089019465ec2a54bc26e9736cf79d4d839a0fc62bb2ac931aa395cd576326a1d7b7c181e741cb943f836904d92ad41871cd
diff --git a/net-misc/gnome-connections/gnome-connections-46.0.ebuild b/net-misc/gnome-connections/gnome-connections-46.0.ebuild
new file mode 100644
index 000000000000..46d9d8af30ae
--- /dev/null
+++ b/net-misc/gnome-connections/gnome-connections-46.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="A remote desktop client for the GNOME desktop environment"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/connections"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~loong"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-libs/gobject-introspection
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection]
+ >=sys-fs/fuse-3.9.1
+ >=net-libs/gtk-vnc-0.4.4[pulseaudio,vala]
+ >=gui-libs/libhandy-1.6.0:1[vala]
+ >=dev-libs/libxml2-2.7.8
+ app-crypt/libsecret[vala]
+
+ >=net-misc/freerdp-2.0.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/glib
+ dev-util/glib-utils
+ dev-util/itstool
+ sys-devel/gettext
+ virtual/pkgconfig
+
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+src_prepare() {
+ default
+ vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}