summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-08-17 23:41:18 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-08-17 23:41:18 +0200
commit14baacb85f7273c87210e5e14918852c776ca2c4 (patch)
treeb791d2e30a369afc89a3ca1eebf657296f46d384 /net-misc/mosh/mosh-1.2.6.ebuild
parentapp-shells/thefuck: Version bump to 3.11 (diff)
downloadgentoo-14baacb85f7273c87210e5e14918852c776ca2c4.tar.gz
gentoo-14baacb85f7273c87210e5e14918852c776ca2c4.tar.bz2
gentoo-14baacb85f7273c87210e5e14918852c776ca2c4.zip
net-misc/mosh: Version bump to 1.2.6
Package-Manager: portage-2.3.0
Diffstat (limited to 'net-misc/mosh/mosh-1.2.6.ebuild')
-rw-r--r--net-misc/mosh/mosh-1.2.6.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/mosh/mosh-1.2.6.ebuild b/net-misc/mosh/mosh-1.2.6.ebuild
new file mode 100644
index 000000000000..a6a0d27c7b60
--- /dev/null
+++ b/net-misc/mosh/mosh-1.2.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools bash-completion-r1 eutils vcs-snapshot
+
+DESCRIPTION="Mobile shell that supports roaming and intelligent local echo"
+HOMEPAGE="http://mosh.mit.edu"
+SRC_URI="http://mosh.mit.edu/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~x64-macos"
+IUSE="+client examples +mosh-hardening +server ufw +utempter"
+
+REQUIRED_USE="|| ( client server )
+ examples? ( client )"
+
+RDEPEND="dev-libs/protobuf
+ sys-libs/ncurses:0=
+ virtual/ssh
+ client? (
+ dev-lang/perl
+ dev-perl/IO-Tty
+ )
+ utempter? (
+ sys-libs/libutempter
+ )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# [0] - avoid sandbox-violation calling git describe in Makefile
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.5-git-version.patch
+)
+
+src_prepare() {
+ # apply patches.
+ epatch ${PATCHES[@]}
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-completion \
+ $(use_enable client) \
+ $(use_enable server) \
+ $(use_enable examples) \
+ $(use_enable ufw) \
+ $(use_enable mosh-hardening hardening) \
+ $(use_with utempter)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ default
+
+ for myprog in $(find src/examples -type f -perm /0111) ; do
+ newbin ${myprog} ${PN}-$(basename ${myprog})
+ elog "${myprog} installed as ${PN}-$(basename ${myprog})"
+ done
+
+ # bug 477384
+ dobashcomp conf/bash-completion/completions/mosh
+}