summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-30 17:36:39 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-30 17:36:39 -0500
commit2ee53e50de8f395620c0c094e111319485860cdc (patch)
treea79eb4351872bc82b0dd54e9b24a5553614e9ba1 /net-misc
parentmedia-libs/ampache_browser: Stabilize 1.0.6 amd64, #921092 (diff)
downloadgentoo-2ee53e50de8f395620c0c094e111319485860cdc.tar.gz
gentoo-2ee53e50de8f395620c0c094e111319485860cdc.tar.bz2
gentoo-2ee53e50de8f395620c0c094e111319485860cdc.zip
net-misc/yt-dlp: add 2023.12.30
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/yt-dlp/Manifest1
-rw-r--r--net-misc/yt-dlp/yt-dlp-2023.12.30.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/net-misc/yt-dlp/Manifest b/net-misc/yt-dlp/Manifest
index e589004e0970..717342362dc5 100644
--- a/net-misc/yt-dlp/Manifest
+++ b/net-misc/yt-dlp/Manifest
@@ -1 +1,2 @@
DIST yt-dlp-2023.11.16.tar.gz 5568397 BLAKE2B 9747ccbb032776df3de78c22084c67cca7913af6b29de9baedb7fe9048feb3e85db1cc1e694fcc563fecb674bad094193ff0a9cab081de9cbb006bce546c8753 SHA512 0d4219d5c2c883a2f10e43b5d93a807f84121f43f781cf494b30000c37d105facce9226bb60367c563e86cf17c4cbb2550ba31cfed6c3b1abb337cd1fb39e414
+DIST yt-dlp-2023.12.30.tar.gz 5402838 BLAKE2B b2cdba23d426f862b8fc7a09002abfa8a6c27a1f1bded987d0b4b412266856d2d0f62dd2bc9cf3e34c671f01539252fc19587dec9a417b2e8f56370ef0f5c610 SHA512 23062e61cae9c51436f16de0a5ee0b351e59554ab4b5b90bed819d98b6b677bfd1797abae5baf52964eb64236c4b7abe23e37ca88ed10cbce3f7356081be59c4
diff --git a/net-misc/yt-dlp/yt-dlp-2023.12.30.ebuild b/net-misc/yt-dlp/yt-dlp-2023.12.30.ebuild
new file mode 100644
index 000000000000..0cd53615678b
--- /dev/null
+++ b/net-misc/yt-dlp/yt-dlp-2023.12.30.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit bash-completion-r1 distutils-r1 optfeature wrapper
+
+DESCRIPTION="youtube-dl fork with additional features and fixes"
+HOMEPAGE="https://github.com/yt-dlp/yt-dlp/"
+SRC_URI="
+ https://github.com/yt-dlp/yt-dlp/releases/download/${PV}/${PN}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ !net-misc/youtube-dl[-yt-dlp(-)]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # adjust requires for pycryptodome and optional dependencies (bug #828466)
+ sed -ri requirements.txt \
+ -e "s/^(pycryptodome)x/\1/" \
+ -e "/^(brotli.*|certifi|mutagen|requests|urllib3|websockets)/d" || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # fails with FEATURES=distcc, bug #915614
+ test/test_networking.py::TestYoutubeDLNetworking::test_proxy\[None-expected2\]
+ )
+
+ epytest -m 'not download'
+}
+
+python_install_all() {
+ dodoc README.md Changelog.md supportedsites.md
+ doman yt-dlp.1
+
+ dobashcomp completions/bash/yt-dlp
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/fish/yt-dlp.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/zsh/_yt-dlp
+
+ rm -r "${ED}"/usr/share/doc/yt_dlp || die
+
+ make_wrapper youtube-dl "yt-dlp --compat-options youtube-dl"
+}
+
+pkg_postinst() {
+ optfeature "various features (merging tracks, streamed content)" media-video/ffmpeg
+ has_version media-video/atomicparsley || # allow fallback but don't advertise
+ optfeature "embedding metadata thumbnails in MP4/M4A files" media-libs/mutagen
+ optfeature "decrypting cookies from Chromium-based browsers" dev-python/secretstorage
+
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog 'A wrapper using "yt-dlp --compat-options youtube-dl" was installed'
+ elog 'as "youtube-dl". This is strictly for compatibility and it is'
+ elog 'recommended to use "yt-dlp" directly, it may be removed in the future.'
+ fi
+}