summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-24 17:41:09 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-24 17:43:06 +0200
commitd971d5cfb00f39d7596498fe074d71bb5975071b (patch)
tree520ce1cfdbffc3a5e98331cf7ea92051c6b4ab5f /net-misc
parentdev-tex/biblatex: add ~arm keyword bug #564550 (diff)
downloadgentoo-d971d5cfb00f39d7596498fe074d71bb5975071b.tar.gz
gentoo-d971d5cfb00f39d7596498fe074d71bb5975071b.tar.bz2
gentoo-d971d5cfb00f39d7596498fe074d71bb5975071b.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.05.21.2.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index ad5aeb119a93..75083d374657 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -2,3 +2,4 @@ DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b
DIST youtube-dl-2016.05.01.tar.gz 2097882 SHA256 adc812e840f8f2461d6b7e72876c9219bfc8004e650a6ac7ddf216ccab5304f0 SHA512 c94c0bb222ca6e866646fef201b53cdf9a6d5a89921f34ef3d557822fe9398268251f9221ac2b5e11b7580d7b566b7795a7d8b7945672f3bc07ef8f11de18969 WHIRLPOOL 641dc9f582fed6ccc9a973e7cfab37540a0ea3483ef7ecc0f057ee9e2f08e1a57eaf2ee4030b2fc501ecf15da731cb7a58a7ecda75f2b999c9cb7cecb8ea8cd0
DIST youtube-dl-2016.05.10.tar.gz 2125075 SHA256 ccb96dd53b7bf7305db0430f8b3a2044fa24f5200903c95349e070f938ad0c3f SHA512 c4976de6ec345325e71798ac4d7d29b3253251b4cf743ff717ba834ace912ae2b9dfb602d31291a2b360255457f37771c5b361fe2a928105ad358558869627fe WHIRLPOOL 9581a78f4d8c76d4a6de161cfbeea449a9e066e2b8831288db6eeaa178f5e0b2e3c085c6fb2ee33e6735124dcd91975c6ad2b006275f2ef88e1719f906259376
DIST youtube-dl-2016.05.16.tar.gz 2127223 SHA256 1d86102cb7f39c1a3441b70287cae55daef9724bacef4534287479d9c5c8ab0e SHA512 b1125f6857dc97a1464f91419b2b762c6aff4b7c2f599c651339797a293dc92f4763deefb4a432db4ac3088fdabd9cacf7d89f6d9725eb5ab50a5b59608df34d WHIRLPOOL 21ed93942ba1cd700e6a418767bfdaeec9f315738e50af2ef7870835d12391188cdfcda5ff11e8b50f06dc94e33d26efa4185b430273e6b6a6add2f535ae1346
+DIST youtube-dl-2016.05.21.2.tar.gz 2156460 SHA256 66f94fc97012c4c7a6338dc4df6ec62af66dcfc144c5e8c8cd8b5519756f1a98 SHA512 0a3b4bac9a1a6d33859936335404c298322e3371a4d1455108e4c32b94e6427371fbcc59bc140c774fbefb42e262c0fc2b4e6a544b8dba687c35d1d7ae65c345 WHIRLPOOL 9b319d6fcbf3da8b03fcd6528f7ac2eaa1ba15da3af7eb035c7f7dc2c3b9f245bbb9cd2521c33f3ef8209f8ee75ad8e37631ee908d2a34f5e5d8001b06b711db
diff --git a/net-misc/youtube-dl/youtube-dl-2016.05.21.2.ebuild b/net-misc/youtube-dl/youtube-dl-2016.05.21.2.ebuild
new file mode 100644
index 000000000000..969c3bf49e3d
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.05.21.2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink camwithher chaturbate drtuber eporner
+ eroprofile extremetube fourtube foxgay goshgay hellporno
+ hentaistigma hornbunny keezmovies lovehomeporn mofosex motherless
+ myvidster porn91 pornhd pornotube pornovoisines pornoxo redtube
+ ruleporn sexu slutload spankbang spankwire sunporno thisav trutube
+ tube8 vporn watchindianporn xbef xnxx xtube xvideos xxxymovies
+ youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/extractors.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+
+ dodoc README.txt
+ doman ${PN}.1
+
+ newbashcomp ${PN}.bash-completion ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/completions
+ doins youtube-dl.fish
+
+ python_fix_shebang "${ED}"
+}