summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nds/nsscache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nds/nsscache')
-rw-r--r--net-nds/nsscache/Manifest3
-rw-r--r--net-nds/nsscache/files/nsscache-0.8.3-starttls.patch53
-rw-r--r--net-nds/nsscache/files/nsscache.conf122
-rw-r--r--net-nds/nsscache/metadata.xml14
-rw-r--r--net-nds/nsscache/nsscache-0.21.14.ebuild47
-rw-r--r--net-nds/nsscache/nsscache-0.23.ebuild42
-rw-r--r--net-nds/nsscache/nsscache-0.8.8.ebuild39
7 files changed, 320 insertions, 0 deletions
diff --git a/net-nds/nsscache/Manifest b/net-nds/nsscache/Manifest
new file mode 100644
index 000000000000..3069bb60036c
--- /dev/null
+++ b/net-nds/nsscache/Manifest
@@ -0,0 +1,3 @@
+DIST nsscache-0.21.14.tar.gz 87708 SHA256 170f89a45b580269d26f9a6d65edaad31290407ebe2234a825299486ad0d89bd SHA512 178aa7748a45d5ad514f57ae1b0ff64b26dd3fd82efbb164f3c3f9a977e07737313a34225afa9b00a15faf5685532030fe23abaf4ab20233187121697e29f463 WHIRLPOOL 2dd83a09bd49b4fd5cefedf043f0a8755a9a64bc2ba30657dc7e84eaf962496ae2bfe2c918659a80af47ed62fe6ab6870430b3ff89aeefe8e1f0d176b5655b95
+DIST nsscache-0.23.tar.gz 92603 SHA256 b33ea574cd6e9c4f5ce57b8fae9dd64a710ec89d3f382c879f0af8c6215d0d9e SHA512 2bce655f6e8b64eb258779f80620d4514729d221ce9ed9ca7f675c22faeca400478827f27befa9cdac5e95f33934609d84d520af71f756721e22aa0c7cef82d6 WHIRLPOOL 78d6e8abdc4d66df667d2c9e3ab4c6e1c065a224283c94ab44bd51209db373d896b7221923d1948e7cdc36dcfc752d9f98162c3ece95955578b9b7c0c5b28dd8
+DIST nsscache-0.8.8.tar.gz 74261 SHA256 3512848b3f37a3055812a5d2c500192df8a396cc39f55e63fdaffc67d1a748e2
diff --git a/net-nds/nsscache/files/nsscache-0.8.3-starttls.patch b/net-nds/nsscache/files/nsscache-0.8.3-starttls.patch
new file mode 100644
index 000000000000..2ca9c1feec9b
--- /dev/null
+++ b/net-nds/nsscache/files/nsscache-0.8.3-starttls.patch
@@ -0,0 +1,53 @@
+Some LDAP configurations require STARTTLS, like the Gentoo infrastructure one.
+Add a new configuration file to do it.
+
+Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
+
+diff -Nuar nsscache-0.8.3.orig/nss_cache/sources/ldapsource.py nsscache-0.8.3/nss_cache/sources/ldapsource.py
+--- nsscache-0.8.3.orig/nss_cache/sources/ldapsource.py 2008-09-08 18:31:58.000000000 -0700
++++ nsscache-0.8.3/nss_cache/sources/ldapsource.py 2009-05-24 16:50:59.579112740 -0700
+@@ -76,6 +76,8 @@
+ self.conn = rlo(uri=conf['uri'],
+ retry_max=conf['retry_max'],
+ retry_delay=conf['retry_delay'])
++ if conf['tls_starttls'] == 1:
++ self.conn.start_tls_s()
+ else:
+ self.conn = conn
+
+@@ -107,6 +109,8 @@
+ configuration['tls_cacertdir'] = self.TLS_CACERTDIR
+ if not 'tls_cacertfile' in configuration:
+ configuration['tls_cacertfile'] = self.TLS_CACERTFILE
++ if not 'tls_starttls' in configuration:
++ configuration['tls_starttls'] = 0
+
+ # Translate tls_require into appropriate constant, if necessary.
+ if configuration['tls_require_cert'] == 'never':
+@@ -120,6 +124,13 @@
+ elif configuration['tls_require_cert'] == 'try':
+ configuration['tls_require_cert'] = ldap.OPT_X_TLS_TRY
+
++ # Should we issue STARTTLS?
++ if configuration['tls_starttls'] in (1, '1', 'on', 'yes', 'true'):
++ configuration['tls_starttls'] = 1
++ #if not configuration['tls_starttls']:
++ else:
++ configuration['tls_starttls'] = 0
++
+ # Setting global ldap defaults.
+ ldap.set_option(ldap.OPT_X_TLS_REQUIRE_CERT,
+ configuration['tls_require_cert'])
+diff -Nuar nsscache-0.8.3.orig/nsscache.conf nsscache-0.8.3/nsscache.conf
+--- nsscache-0.8.3.orig/nsscache.conf 2008-09-08 18:31:58.000000000 -0700
++++ nsscache-0.8.3/nsscache.conf 2009-05-24 16:51:25.468374563 -0700
+@@ -70,6 +70,9 @@
+ # Default filename for trusted CAs
+ #ldap_tls_cacertfile = '/usr/share/ssl/cert.pem'
+
++# Should we issue STARTTLS?
++# ldap_tls_starttls = 1
++
+
+ ##
+ # nssdb module defaults
diff --git a/net-nds/nsscache/files/nsscache.conf b/net-nds/nsscache/files/nsscache.conf
new file mode 100644
index 000000000000..c17f4a2df9c8
--- /dev/null
+++ b/net-nds/nsscache/files/nsscache.conf
@@ -0,0 +1,122 @@
+# Example /etc/nsscache.conf - configuration for nsscache
+#
+# nsscache loads a config file from the environment variable NSSCACHE_CONFIG
+#
+# By default this is /etc/nsscache.conf
+#
+# Commented values are overrideable defaults, uncommented values
+# require you to set them.
+
+[DEFAULT]
+
+# Default NSS data source module name
+source = ldap
+
+# Default NSS data cache module name
+cache = nssdb
+#cache = files
+
+# NSS maps to be cached
+maps = passwd, group, shadow, netgroup
+
+# Directory to store our update/modify timestamps
+timestamp_dir = /var/lib/nsscache
+
+# Lockfile to use for update/repair operations
+#lockfile = /var/run/nsscache
+
+# Defaults for specific modules; prefaced with "modulename_"
+
+##
+# ldap module defaults.
+#
+
+# LDAP URI to query for NSS data
+ldap_uri = ldaps://ldap
+
+# Base for LDAP searches
+ldap_base = ou=people,dc=example,dc=com
+
+# Default LDAP search filter for maps
+ldap_filter = (objectclass=posixAccount)
+
+# Default LDAP search scope
+#ldap_scope = one
+
+# Default LDAP BIND DN, empty string is an anonymous bind
+#ldap_bind_dn = ""
+
+# Default LDAP password, empty DN and empty password is used for
+# anonymous binds
+#ldap_bind_password = ""
+
+# Default timelimit for LDAP queries, in seconds.
+# The query will block for this number of seconds, or indefinitely if negative.
+#ldap_timelimit = -1
+
+# Default number of retry attempts
+#ldap_retry_max = 3
+
+# Default delay in between retry attempts
+#ldap_retry_delay = 5
+
+# Default setting for requiring tls certificates, one of:
+# never, hard, demand, allow, try
+#ldap_tls_require_cert = 'demand'
+
+# Default directoy for trusted CAs
+#ldap_tls_cacertdir = '/usr/share/ssl'
+
+# Default filename for trusted CAs
+#ldap_tls_cacertfile = '/usr/share/ssl/cert.pem'
+
+# Should we issue STARTTLS?
+# ldap_tls_starttls = 1
+
+##
+# nssdb module defaults
+
+# Directory to store nssdb databases. Current libnss_db code requires
+# the path below
+#nssdb_dir = /var/lib/misc
+
+# Path to `makedb', supplied by the nss_db module
+#nssdb_makedb = /usr/bin/makedb
+
+##
+# files module defaults
+
+# Directory to store the plain text files
+#files_dir = /etc
+
+# Suffix used on the files module database files
+files_cache_filename_suffix = cache
+
+###
+# Optional per-map sections, if present they will override the above
+# defaults. The examples below show you some common values to override
+#
+# [passwd]
+#
+# ldap_base = ou=people,dc=example,dc=com
+
+[group]
+
+ldap_base = ou=group,dc=example,dc=com
+ldap_filter = (objectclass=posixGroup)
+
+[shadow]
+
+ldap_filter = (objectclass=shadowAccount)
+
+[netgroup]
+
+ldap_base = ou=netgroup,dc=example,dc=com
+ldap_filter = (objectclass=nisNetgroup)
+files_cache_filename_suffix =
+
+[automount]
+
+ldap_base = ou=automounts,dc=example,dc=com
+files_cache_filename_suffix =
+cache = files
diff --git a/net-nds/nsscache/metadata.xml b/net-nds/nsscache/metadata.xml
new file mode 100644
index 000000000000..66627b6b4458
--- /dev/null
+++ b/net-nds/nsscache/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="nssdb">Depend on sys-libs/libnss_db to handle dbm files.</flag>
+ <flag name="nsscache">Depend on sys-auth/libnss-cache to handle flat files</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">nsscache</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-nds/nsscache/nsscache-0.21.14.ebuild b/net-nds/nsscache/nsscache-0.21.14.ebuild
new file mode 100644
index 000000000000..fc9f0f01058a
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.21.14.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+PYTHON_USE_WITH="berkdb"
+PYTHON_USE_WITH_OPT="nssdb"
+
+inherit eutils python distutils
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="http://code.google.com/p/nsscache/"
+SRC_URI="http://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nssdb nsscache"
+
+DEPEND="dev-python/python-ldap
+ dev-python/pycurl"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+RESTRICT="test"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-0.8.3-starttls.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ # overwrite default with working config.
+ insinto /etc
+ doins "${FILESDIR}/nsscache.conf" || die
+
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+
+ keepdir /var/lib/nsscache
+}
diff --git a/net-nds/nsscache/nsscache-0.23.ebuild b/net-nds/nsscache/nsscache-0.23.ebuild
new file mode 100644
index 000000000000..0490d769e627
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.23.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+PYTHON_USE_WITH="berkdb"
+PYTHON_USE_WITH_OPT="nssdb"
+
+inherit eutils python distutils
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="http://code.google.com/p/nsscache/"
+SRC_URI="http://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nssdb nsscache"
+
+DEPEND="dev-python/python-ldap
+ dev-python/pycurl"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( >=sys-auth/libnss-cache-0.10 )"
+RESTRICT="test"
+
+src_prepare() {
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+
+ keepdir /var/lib/nsscache
+}
diff --git a/net-nds/nsscache/nsscache-0.8.8.ebuild b/net-nds/nsscache/nsscache-0.8.8.ebuild
new file mode 100644
index 000000000000..0e9363073dfd
--- /dev/null
+++ b/net-nds/nsscache/nsscache-0.8.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit eutils python distutils
+
+DESCRIPTION="commandline tool to sync directory services to local cache"
+HOMEPAGE="http://code.google.com/p/nsscache/"
+SRC_URI="http://nsscache.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nssdb nsscache"
+
+DEPEND="dev-python/python-ldap"
+RDEPEND="${DEPEND}
+ nssdb? ( sys-libs/nss-db )
+ nsscache? ( sys-auth/libnss-cache )"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}"/${PN}-0.8.3-starttls.patch
+}
+
+src_install() {
+ distutils_src_install
+ insinto /etc
+ doins "${FILESDIR}/nsscache.conf" # overwrite default with working config.
+ doman nsscache.1 nsscache.conf.5
+ dodoc THANKS nsscache.cron
+ keepdir /var/lib/nsscache
+}