summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/3proxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/3proxy')
-rw-r--r--net-proxy/3proxy/3proxy-0.5.3k.ebuild56
-rw-r--r--net-proxy/3proxy/3proxy-0.6.1.ebuild52
-rw-r--r--net-proxy/3proxy/Manifest2
-rw-r--r--net-proxy/3proxy/files/3proxy-0.5.3k-gentoo.patch26
-rw-r--r--net-proxy/3proxy/files/3proxy-0.6-gentoo.patch34
-rw-r--r--net-proxy/3proxy/metadata.xml10
6 files changed, 180 insertions, 0 deletions
diff --git a/net-proxy/3proxy/3proxy-0.5.3k.ebuild b/net-proxy/3proxy/3proxy-0.5.3k.ebuild
new file mode 100644
index 000000000000..8ff6826b4e2e
--- /dev/null
+++ b/net-proxy/3proxy/3proxy-0.5.3k.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="really tiny cross-platform proxy servers set"
+HOMEPAGE="http://www.security.nnov.ru/soft/3proxy/"
+SRC_URI="http://www.security.nnov.ru/soft/3proxy/${PV}/${P}.tgz"
+
+LICENSE="3proxy"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LN="$(tc-getCC)" \
+ -f Makefile.unix \
+ || die "emake failed"
+}
+
+src_install() {
+ local x
+
+ pushd src
+ dobin 3proxy || die "dobin 3proxy failed"
+ for x in proxy socks ftppr pop3p tcppm udppm mycrypt dighosts ; do
+ newbin ${x} ${PN}-${x} || die "newbin ${x} failed"
+ [[ -f ${S}/man/${x}.8 ]] \
+ && newman "${S}"/man/${x}.8 ${PN}-${x}.8
+ done
+ popd
+
+ doman "${S}"/man/3proxy*.[38]
+
+ cd "${S}"
+ dodoc Changelog Readme Release.notes
+ dohtml -r doc/html/*
+ docinto cfg
+ dodoc cfg/*.{txt,sample}
+ docinto cfg/sql
+ dodoc cfg/sql/*.{cfg,sql}
+}
diff --git a/net-proxy/3proxy/3proxy-0.6.1.ebuild b/net-proxy/3proxy/3proxy-0.6.1.ebuild
new file mode 100644
index 000000000000..586a0bc73b84
--- /dev/null
+++ b/net-proxy/3proxy/3proxy-0.6.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="really tiny cross-platform proxy servers set"
+HOMEPAGE="http://3proxy.ru/"
+SRC_URI="http://3proxy.ru/${PV}/${P}.tgz"
+
+LICENSE="3proxy"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.6-gentoo.patch
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LN="$(tc-getCC)" \
+ LIBS="-ldl" \
+ -f Makefile.unix \
+ || die "emake failed"
+}
+
+src_install() {
+ local x
+
+ pushd src
+ dobin 3proxy || die "dobin 3proxy failed"
+ for x in proxy socks ftppr pop3p tcppm udppm mycrypt dighosts countersutil ; do
+ newbin ${x} ${PN}-${x} || die "newbin ${x} failed"
+ [[ -f ${S}/man/${x}.8 ]] \
+ && newman "${S}"/man/${x}.8 ${PN}-${x}.8
+ done
+ popd
+
+ doman "${S}"/man/3proxy*.[38]
+
+ cd "${S}"
+ dodoc Changelog Readme
+ dohtml -r doc/html/*
+ docinto cfg
+ dodoc cfg/*.{txt,sample}
+ docinto cfg/sql
+ dodoc cfg/sql/*.{cfg,sql}
+}
diff --git a/net-proxy/3proxy/Manifest b/net-proxy/3proxy/Manifest
new file mode 100644
index 000000000000..956dc07add6e
--- /dev/null
+++ b/net-proxy/3proxy/Manifest
@@ -0,0 +1,2 @@
+DIST 3proxy-0.5.3k.tgz 190797 SHA256 7bbe159a0157480c653ef3976495a9b1993435a44ea0e7c03784320e3ac28ea3
+DIST 3proxy-0.6.1.tgz 480160 SHA256 10f8804258791e80353a334dc9b80473a02c6dda939de76451e655f643aadd7f
diff --git a/net-proxy/3proxy/files/3proxy-0.5.3k-gentoo.patch b/net-proxy/3proxy/files/3proxy-0.5.3k-gentoo.patch
new file mode 100644
index 000000000000..a88a28780432
--- /dev/null
+++ b/net-proxy/3proxy/files/3proxy-0.5.3k-gentoo.patch
@@ -0,0 +1,26 @@
+--- Makefile.unix.orig 2005-04-30 18:29:00.000000000 +0000
++++ Makefile.unix 2008-10-12 17:18:21.000000000 +0000
+@@ -9,10 +9,10 @@
+ CC = gcc
+
+ # you may need -L/usr/pkg/lib for older NetBSD versions
+-CFLAGS = -Wall -g -O2 -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
++CFLAGS += -Wall -g -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+ COUT = -o
+ LN = gcc
+-LDFLAGS = -Wall -O2 -pthread
++LDFLAGS += -Wall -pthread
+ # -lpthreads may be reuqired on some platforms instead of -pthreads
+ LIBS =
+ LNOUT = -o
+--- src/stringtable.c.orig 2008-01-09 21:14:46.000000000 +0000
++++ src/stringtable.c 2008-10-12 17:19:19.000000000 +0000
+@@ -23,7 +23,7 @@
+ /* 19 */ NULL,
+ #ifndef TPROXY_CONF
+ #ifndef _WIN32
+-/* 20 */ (unsigned char *)"/usr/local/etc/3proxy.cfg",
++/* 20 */ (unsigned char *)"/etc/3proxy.cfg",
+ #else
+ /* 20 */ (unsigned char *)"3proxy.cfg",
+ #endif
diff --git a/net-proxy/3proxy/files/3proxy-0.6-gentoo.patch b/net-proxy/3proxy/files/3proxy-0.6-gentoo.patch
new file mode 100644
index 000000000000..c3c4df4edbcb
--- /dev/null
+++ b/net-proxy/3proxy/files/3proxy-0.6-gentoo.patch
@@ -0,0 +1,34 @@
+diff -Nru 3proxy-0.6.orig/Makefile.unix 3proxy-0.6/Makefile.unix
+--- 3proxy-0.6.orig/Makefile.unix 2007-04-10 16:29:25.000000000 +0000
++++ 3proxy-0.6/Makefile.unix 2009-03-24 19:13:09.000000000 +0000
+@@ -12,10 +12,10 @@
+ CC = gcc
+
+ # you may need -L/usr/pkg/lib for older NetBSD versions
+-CFLAGS = -Wall -g -O2 -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
++CFLAGS += -Wall -g -c -pthread -D_THREAD_SAFE -D_REENTRANT -DNOODBC -DWITH_STD_MALLOC -DFD_SETSIZE=4096 -DWITH_POLL
+ COUT = -o
+ LN = gcc
+-LDFLAGS = -Wall -O2 -pthread
++LDFLAGS += -Wall -pthread
+ # -lpthreads may be reuqired on some platforms instead of -pthreads
+ # -ldl or -lld may be required for some platforms
+ DCFLAGS = -fpic
+@@ -55,4 +55,4 @@
+ fi
+
+ allplugins:
+- @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; make ; cd ../.. ; done
++ @list='$(PLUGINS)'; for p in $$list; do cp Makefile Makefile.var plugins/$$p; cd plugins/$$p ; $(MAKE) ; cd ../.. ; done
+diff -Nru 3proxy-0.6.orig/src/stringtable.c 3proxy-0.6/src/stringtable.c
+--- 3proxy-0.6.orig/src/stringtable.c 2008-02-03 11:28:24.000000000 +0000
++++ 3proxy-0.6/src/stringtable.c 2009-03-24 19:12:44.000000000 +0000
+@@ -38,7 +38,7 @@
+ /* 24 */ NULL,
+ #ifndef TPROXY_CONF
+ #ifndef _WIN32
+-/* 25 */ (unsigned char *)"/usr/local/etc/3proxy/3proxy.cfg",
++/* 25 */ (unsigned char *)"/etc/3proxy.cfg",
+ #else
+ /* 25 */ (unsigned char *)"3proxy.cfg",
+ #endif
diff --git a/net-proxy/3proxy/metadata.xml b/net-proxy/3proxy/metadata.xml
new file mode 100644
index 000000000000..da729ce2ae4a
--- /dev/null
+++ b/net-proxy/3proxy/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+<longdescription>3Proxy is really tiny cross-platform proxy servers set. It includes HTTP proxy with HTTPS and FTP support,
+SOCKSv4/SOCKSv4.5/SOCKSv5 proxy, POP3 proxy, FTP proxy, TCP and UDP portmappers. You can use every proxy as a standalone program
+(socks, proxy, tcppm, udppm, pop3p) or use combined program (3proxy). Combined proxy additionally supports features like
+access control, bandwidth limiting, limiting daily/weekly/monthly traffic amount, proxy chaining, log rotation, sylog and ODBC logging, etc.
+It's created to be small, simple (I'd like to say secure - but it's just a beta) and yet functional.</longdescription>
+</pkgmetadata>