summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/ratproxy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/ratproxy')
-rw-r--r--net-proxy/ratproxy/Manifest1
-rw-r--r--net-proxy/ratproxy/files/ratproxy-Makefile.patch19
-rw-r--r--net-proxy/ratproxy/metadata.xml17
-rw-r--r--net-proxy/ratproxy/ratproxy-1.58.ebuild42
4 files changed, 79 insertions, 0 deletions
diff --git a/net-proxy/ratproxy/Manifest b/net-proxy/ratproxy/Manifest
new file mode 100644
index 000000000000..8d3a95409b63
--- /dev/null
+++ b/net-proxy/ratproxy/Manifest
@@ -0,0 +1 @@
+DIST ratproxy-1.58.tar.gz 168700 SHA256 2142d5643305713d9be7fcc82a244048076190851e697b645c49b549a7ae0725
diff --git a/net-proxy/ratproxy/files/ratproxy-Makefile.patch b/net-proxy/ratproxy/files/ratproxy-Makefile.patch
new file mode 100644
index 000000000000..323b52d1ff13
--- /dev/null
+++ b/net-proxy/ratproxy/files/ratproxy-Makefile.patch
@@ -0,0 +1,19 @@
+--- Makefile.bak 2008-07-08 21:34:10.000000000 +0200
++++ Makefile 2008-07-08 21:35:34.000000000 +0200
+@@ -20,13 +20,13 @@
+ #
+
+ PROGNAME = ratproxy
+-CFLAGS = -Wall -O3 -Wno-pointer-sign -D_GNU_SOURCE
+-LDFLAGS = -lcrypto -lssl
++CFLAGS += -Wall -Wno-pointer-sign -D_GNU_SOURCE
++LIBS = -lcrypto -lssl
+
+ all: $(PROGNAME) flare-check
+
+ $(PROGNAME): $(PROGNAME).c http.c mime.c ssl.c http.h mime.h ssl.h nlist.h config.h debug.h types.h string-inl.h
+- $(CC) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS) http.c mime.c ssl.c $(LDFLAGS)
++ $(CC) $(PROGNAME).c -o $(PROGNAME) $(CFLAGS) $(LDFLAGS) http.c mime.c ssl.c $(LIBS)
+
+ flare-check:
+ @flare-dist/flare 2>&1 | grep -qF Igor || ( \
diff --git a/net-proxy/ratproxy/metadata.xml b/net-proxy/ratproxy/metadata.xml
new file mode 100644
index 000000000000..f99494e17823
--- /dev/null
+++ b/net-proxy/ratproxy/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription lang="en">A semi-automated, largely passive web application security audit tool,
+ optimized for an accurate and sensitive detection, and automatic
+ annotation, of potential problems and security-relevant design patterns
+ based on the observation of existing, user-initiated traffic in complex
+ web 2.0 environments.
+ Detects and prioritizes broad classes of security problems, such as
+ dynamic cross-site trust model considerations, script inclusion issues,
+ content serving problems, insufficient XSRF and XSS defenses, and much
+ more.</longdescription>
+ <upstream>
+ <remote-id type="google-code">ratproxy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-proxy/ratproxy/ratproxy-1.58.ebuild b/net-proxy/ratproxy/ratproxy-1.58.ebuild
new file mode 100644
index 000000000000..2a8a70ef7305
--- /dev/null
+++ b/net-proxy/ratproxy/ratproxy-1.58.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="A semi-automated, largely passive web application security audit tool"
+HOMEPAGE="http://code.google.com/p/ratproxy/"
+SRC_URI="http://ratproxy.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/openssl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s:keyfile\.pem:/usr/share/${PN}/&:" ssl.c
+ sed -r -i -e "s:(ratproxy-back\.png|messages\.list):/usr/share/${PN}/&:" ratproxy-report.sh
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN}-report.sh || die "install failed"
+ dobin ${PN} || die "install failed"
+ dodoc doc/{README,TODO}
+ insinto /usr/share/${PN}
+ doins keyfile.pem ratproxy-back.png messages.list
+}