summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-voip/telepathy-gabble
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-voip/telepathy-gabble')
-rw-r--r--net-voip/telepathy-gabble/Manifest1
-rw-r--r--net-voip/telepathy-gabble/metadata.xml9
-rw-r--r--net-voip/telepathy-gabble/telepathy-gabble-0.18.3.ebuild72
3 files changed, 82 insertions, 0 deletions
diff --git a/net-voip/telepathy-gabble/Manifest b/net-voip/telepathy-gabble/Manifest
new file mode 100644
index 000000000000..0a8bc3bbcf54
--- /dev/null
+++ b/net-voip/telepathy-gabble/Manifest
@@ -0,0 +1 @@
+DIST telepathy-gabble-0.18.3.tar.gz 2793195 SHA256 8ec714607e9bcb8d5a3f44adf871e7b07d5db8e326e47536e74e09cba59989c2 SHA512 51c7b754779d131c54facf8e373338bd471e6bb589d69cd8f9c0f4450b15d9676c2bbf762b64e9c3bf7067bca0e9accb6c766f2fda0051a26a36eb009d7bd5eb WHIRLPOOL e1e1e11e8a64c4587e74188827ad62ca702f7058d7d781fa7b982514bf5c16f24bb7711d38a36c113738303e9c0a90727cf57761818c55360ebf13c737d3f2c2
diff --git a/net-voip/telepathy-gabble/metadata.xml b/net-voip/telepathy-gabble/metadata.xml
new file mode 100644
index 000000000000..e301005c66dc
--- /dev/null
+++ b/net-voip/telepathy-gabble/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+<use>
+ <flag name="plugins">Enable plugin loader</flag>
+</use>
+</pkgmetadata>
+
diff --git a/net-voip/telepathy-gabble/telepathy-gabble-0.18.3.ebuild b/net-voip/telepathy-gabble/telepathy-gabble-0.18.3.ebuild
new file mode 100644
index 000000000000..dd8b1c6399f7
--- /dev/null
+++ b/net-voip/telepathy-gabble/telepathy-gabble-0.18.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit gnome2 eutils python-any-r1
+
+DESCRIPTION="A Jabber/XMPP connection manager, with handling of single and multi user chats and voice calls"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
+IUSE="gnutls +jingle plugins test"
+
+# Prevent false positives due nested configure
+QA_CONFIGURE_OPTIONS=".*"
+
+# FIXME: missing sasl-2 for tests ? (automagic)
+# missing libiphb for wocky ?
+# x11-libs/gtksourceview:3.0 needed by telepathy-gabble-xmpp-console, bug #495184
+RDEPEND="
+ >=dev-libs/glib-2.32:2
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.82
+ >=net-libs/telepathy-glib-0.19.9
+
+ dev-db/sqlite:3
+ dev-libs/libxml2
+
+ gnutls? ( >=net-libs/gnutls-2.10.2 )
+ !gnutls? ( >=dev-libs/openssl-0.9.8g:0[-bindist] )
+ jingle? ( || ( net-libs/libsoup:2.4[ssl]
+ >=net-libs/libsoup-2.33.1 )
+ >=net-libs/libnice-0.0.11 )
+ plugins? ( x11-libs/gtksourceview:3.0[introspection] )
+
+ !<net-im/telepathy-mission-control-5.5.0
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-util/gtk-doc-am-1.17
+ dev-libs/libxslt
+ test? ( >=dev-python/twisted-core-0.8.2
+ >=dev-python/twisted-words-0.8.2
+ >=dev-python/dbus-python-0.83 )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-coding-style-checks \
+ --disable-static \
+ --disable-Werror \
+ --enable-file-transfer \
+ $(use_enable jingle voip) \
+ $(use_enable jingle google-relay) \
+ $(use_enable plugins) \
+ --with-tls=$(usex gnutls gnutls openssl)
+}
+
+src_test() {
+ # Twisted tests fail, upstream bug #30565
+ emake -C tests check-TESTS
+}