summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Korepanov <kaikaikai@yandex.ru>2022-12-24 23:21:53 +0000
committerSam James <sam@gentoo.org>2022-12-27 10:23:14 +0000
commit1c52b88c5da8123227ec3490d1b73df1849af4c5 (patch)
treea182786e246cb347d00d861c78d09a3343d66c6d /net-vpn
parentnet-libs/libvncserver: version bump to 0.9.14 (diff)
downloadgentoo-1c52b88c5da8123227ec3490d1b73df1849af4c5.tar.gz
gentoo-1c52b88c5da8123227ec3490d1b73df1849af4c5.tar.bz2
gentoo-1c52b88c5da8123227ec3490d1b73df1849af4c5.zip
net-vpn/i2pd: version bump 2.44.0
Signed-off-by: Alexey Korepanov <kaikaikai@yandex.ru> Bug: https://bugs.gentoo.org/884894 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/i2pd/Manifest1
-rw-r--r--net-vpn/i2pd/i2pd-2.44.0.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/net-vpn/i2pd/Manifest b/net-vpn/i2pd/Manifest
index bbfdf8545647..1d65e893885b 100644
--- a/net-vpn/i2pd/Manifest
+++ b/net-vpn/i2pd/Manifest
@@ -1,2 +1,3 @@
DIST i2pd-2.42.1.tar.gz 615872 BLAKE2B b3e2e070e616d6908f8024dd83ca2fe77aa76ba233a62575ac0b36767448a4741fb227c3b326179355ff9c11acf887600e70697226baef6ade2d945c5e4c34bb SHA512 85df4d8d0a18bf7f3095191a5181a1fa864bfad7b84d2fc18a089b964d80166727f010dcd55a0c8fb1c4e385e1b35b3a1d975f0c0c2efa70999f3c19aba08d97
DIST i2pd-2.43.0.tar.gz 638031 BLAKE2B 5e954fb62198a229fc8de9ca48655a67e8e9a0eabfa7f31dcaaaf42149239565968f16825eb25b202b6a5754938ce82d28cd2631e085dfa358bcd27ced089bd5 SHA512 7247850cd47cccc540346b4a1becc6dba5f40bcb333cd722e9fc59fd8b0beddee700376829d29add05cea6b84bb34303ed37e01914a1a41cf8cd94fe5c826e4a
+DIST i2pd-2.44.0.tar.gz 648523 BLAKE2B f9b29da82c943d070c09ed3ee78ceb7759c015da8a2da19c24cbf2d9841c7869920cbafd6212ada2e285b8b263d1a719220ba9dabb20807ccb78d2576383d167 SHA512 8760fb8a501ee75ede0ec29d3e9f39efec3bc91490810b39ac4879dbc073239e779e179c0f44bc43ba31fa0b786fd652d8b6feda415731e8fc3f4c0781400e1e
diff --git a/net-vpn/i2pd/i2pd-2.44.0.ebuild b/net-vpn/i2pd/i2pd-2.44.0.ebuild
new file mode 100644
index 000000000000..c60616e944bc
--- /dev/null
+++ b/net-vpn/i2pd/i2pd-2.44.0.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs systemd
+
+DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
+HOMEPAGE="https://github.com/PurpleI2P/i2pd"
+SRC_URI="https://github.com/PurpleI2P/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cpu_flags_x86_aes cpu_flags_x86_avx i2p-hardening +upnp"
+
+RDEPEND="
+ acct-user/i2pd
+ acct-group/i2pd
+ dev-libs/boost:=
+ dev-libs/openssl:0=[-bindist(-)]
+ sys-libs/zlib
+ upnp? ( net-libs/miniupnpc:= )"
+DEPEND="${RDEPEND}"
+
+CMAKE_USE_DIR="${WORKDIR}/${P}/build"
+
+DOCS=( ../README.md ../contrib/i2pd.conf ../contrib/tunnels.conf )
+
+pkg_pretend() {
+ if use i2p-hardening && ! tc-is-gcc; then
+ die "i2p-hardening requires gcc"
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_AESNI=$(usex cpu_flags_x86_aes ON OFF)
+ -DWITH_HARDENING=$(usex i2p-hardening ON OFF)
+ -DWITH_STATIC=OFF
+ -DWITH_UPNP=$(usex upnp ON OFF)
+ -DWITH_LIBRARY=ON
+ -DWITH_BINARY=ON
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # config
+ insinto /etc/i2pd
+ doins contrib/i2pd.conf
+ doins contrib/tunnels.conf
+
+ # working directory
+ insinto /var/lib/i2pd
+ doins -r contrib/certificates
+
+ # add /var/lib/i2pd/certificates to CONFIG_PROTECT
+ doenvd "${FILESDIR}/99i2pd"
+
+ # openrc and systemd daemon routines
+ newconfd "${FILESDIR}/i2pd-2.6.0-r3.confd" i2pd
+ newinitd "${FILESDIR}/i2pd-2.39.0.initd" i2pd
+ systemd_newunit "${FILESDIR}/i2pd-2.38.0.service" i2pd.service
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/i2pd-2.38.0-r1.logrotate" i2pd
+}
+
+pkg_postinst() {
+ if [[ -f ${EROOT}/etc/i2pd/subscriptions.txt ]]; then
+ ewarn
+ ewarn "Configuration of the subscriptions has been moved from"
+ ewarn "subscriptions.txt to i2pd.conf. We recommend updating"
+ ewarn "i2pd.conf accordingly and deleting subscriptions.txt."
+ fi
+}