summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-07-11 20:18:19 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-07-14 16:07:19 +0200
commit549566a9afd3fcb98469ba7c960c922d264f4a72 (patch)
treed1c49a5bb553ed3d2db384098291c6712055584f /net-vpn
parentsys-apps/ckbcomp: add 1.230 (diff)
downloadgentoo-549566a9afd3fcb98469ba7c960c922d264f4a72.tar.gz
gentoo-549566a9afd3fcb98469ba7c960c922d264f4a72.tar.bz2
gentoo-549566a9afd3fcb98469ba7c960c922d264f4a72.zip
net-vpn/openfortivpn: add 1.22.1
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/37519 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/openfortivpn/Manifest1
-rw-r--r--net-vpn/openfortivpn/openfortivpn-1.22.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-vpn/openfortivpn/Manifest b/net-vpn/openfortivpn/Manifest
index b88e7b43c9a1..86e7a9166727 100644
--- a/net-vpn/openfortivpn/Manifest
+++ b/net-vpn/openfortivpn/Manifest
@@ -1,3 +1,4 @@
DIST openfortivpn-1.19.0.tar.gz 168962 BLAKE2B f2cff6f89a0662aca5911f6c3ef5953181383d4a66a41df83916c551338f07364436a174de39874cb654d6538955ac5d0a57a875facf2cc9b8c8a27a48df7fbf SHA512 4f4179178cbf2fc03ddebdfd4197c03a7108ecfa5216d5f11d80b2e3b840816f0a9a59714f58ecdcf966b76eb9b459e0bf78901940120ed1aa1cf69021385a53
DIST openfortivpn-1.20.2.tar.gz 167680 BLAKE2B fec9ef5f38af6cf32283cb281d0871115c3ddface35bbbe5fb96cd132cf2f586bd21ddaf55424bc902ea3984472109ec40ee4fd16706d10cc1795b4d68216b1d SHA512 e3ad8e74f7ba05f61df464af8a6ff6ba41e0c73ad52fbb9eaa9485814788a4636800b91cdd88f88caecbc9e305b2759a628b02fbe2eaf12d33c7912bb3ce065b
DIST openfortivpn-1.20.3.tar.gz 168568 BLAKE2B ef6132c354c0348d09584675d7fe0213bf67f78df6ef36434f7e7d5166e6a7ec2dd4352613271f208a72b7666a6259642156bd297485714f9bc53f09fd2dce17 SHA512 38a1b208c2cbba1b1f723d6f8a2e178970b8fd384dbb424c38654821d56fc1652bae27b7593cd6af3c08d7c9b8cf97550185905b690e6eae7222b31aea266f01
+DIST openfortivpn-1.22.1.tar.gz 171440 BLAKE2B cd8024985f9242799bd42708e46b6080b75cf1b1281d0f9c29f767dc83e7f6a9338fa271e82f3c73fe94ab05d8d309fe7a78f5270b036bc33d9d19d873609b05 SHA512 a6d3342689c733534c37f023f5a25dfc5bbb00bc3a0f9531b7cef1dc2825b48dc00ba68798a760316e644eefde98355fba8f1673c17af51f876c5b2a54828e37
diff --git a/net-vpn/openfortivpn/openfortivpn-1.22.1.ebuild b/net-vpn/openfortivpn/openfortivpn-1.22.1.ebuild
new file mode 100644
index 000000000000..a172d6c2da5d
--- /dev/null
+++ b/net-vpn/openfortivpn/openfortivpn-1.22.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info
+
+DESCRIPTION="Fortinet compatible VPN client"
+HOMEPAGE="https://github.com/adrienverge/openfortivpn"
+SRC_URI="https://github.com/adrienverge/openfortivpn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3-with-openssl-exception openssl"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/openssl:=
+ net-dialup/ppp
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~PPP ~PPP_ASYNC"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.02.3-systemd_substitute_bin_and_sysconfig_dirs.patch
+ "${FILESDIR}"/${PN}-1.20.3-pppd-ipcp-accept-remote.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i 's/-Werror//g' Makefile.am || die "Failed to remove -Werror from Makefile.am"
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ keepdir /etc/openfortivpn
+}