summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2023-07-21 10:53:13 +0200
committerPacho Ramos <pacho@gentoo.org>2023-07-21 10:55:03 +0200
commit7dabbaaa3f7252e981fe1774c858a79c6ee9be0b (patch)
tree10ed12e7f1dd15b2a33d1e69b9f14a5bed60b6b8 /sci-biology/biopython/biopython-1.81-r1.ebuild
parentdev-ruby/actiontext: depend on specific minitest slot (diff)
downloadgentoo-7dabbaaa3f7252e981fe1774c858a79c6ee9be0b.tar.gz
gentoo-7dabbaaa3f7252e981fe1774c858a79c6ee9be0b.tar.bz2
gentoo-7dabbaaa3f7252e981fe1774c858a79c6ee9be0b.zip
sci-biology/biopython: use PEP517 build
Also apply Fedora patches to get ready for newer reportlab and python3.12 Closes: https://bugs.gentoo.org/910016 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'sci-biology/biopython/biopython-1.81-r1.ebuild')
-rw-r--r--sci-biology/biopython/biopython-1.81-r1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/sci-biology/biopython/biopython-1.81-r1.ebuild b/sci-biology/biopython/biopython-1.81-r1.ebuild
new file mode 100644
index 000000000000..115a4d3b1a4c
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.81-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517="setuptools"
+DISTUTILS_EXT=1
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python modules for computational molecular biology"
+HOMEPAGE="https://www.biopython.org/ https://pypi.org/project/biopython/"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/networkx[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ >=dev-python/reportlab-3.5.13-r1[${PYTHON_USEDEP}]
+ dev-python/pydot[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-devel/flex"
+
+DOCS=( {CONTRIB,DEPRECATED,NEWS,README}.rst Doc/. )
+
+PATCHES=(
+ "${FILESDIR}/${P}-reportlab4.patch"
+ "${FILESDIR}/${P}-python3.12.patch"
+)
+
+python_test() {
+ cd Tests || die
+ "${EPYTHON}" run_tests.py --offline --verbose || die
+}
+
+python_install_all() {
+ # remove files causing ecompressdir to fail
+ rm Doc/examples/ls_orchid.gbk.{gz,bz2} || die
+
+ distutils-r1_python_install_all
+
+ dodir /usr/share/${PN}
+ cp -r --preserve=mode Scripts Tests "${ED}"/usr/share/${PN} || die
+}
+
+pkg_postinst() {
+ optfeature_header "For database support you need to install:"
+ optfeature "MySQL database support" dev-python/mysqlclient
+ optfeature "PostgreSQL database support" dev-python/psycopg:2
+
+ optfeature_header "Some applications need extra packages:"
+ optfeature "EMBOSS (The European Molecular Biology Open Software Suite)" sci-biology/emboss
+}