summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-03-26 12:06:21 +0100
committerDavid Seifert <soap@gentoo.org>2024-03-26 12:06:21 +0100
commit0663dbd3daa9a4f9716f1238a3248e23a97767fa (patch)
tree04df1470e41ba7deefebb40c8c36c882c26c57a0 /sci-biology
parentsci-libs/htslib: add 1.19.1 (diff)
downloadgentoo-0663dbd3daa9a4f9716f1238a3248e23a97767fa.tar.gz
gentoo-0663dbd3daa9a4f9716f1238a3248e23a97767fa.tar.bz2
gentoo-0663dbd3daa9a4f9716f1238a3248e23a97767fa.zip
sci-biology/samtools: add 1.19.2
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/samtools/Manifest1
-rw-r--r--sci-biology/samtools/samtools-1.19.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-biology/samtools/Manifest b/sci-biology/samtools/Manifest
index 72408c9c9544..09cffe1bb5b0 100644
--- a/sci-biology/samtools/Manifest
+++ b/sci-biology/samtools/Manifest
@@ -1 +1,2 @@
DIST samtools-1.17.tar.bz2 8605080 BLAKE2B 09cb0bff7bf7113a77f57fdb879765b28b65461a574e4a1ab20ae2327af46e5616e04f03eb68706d42ba0643e887d7921974a3d78c5f87d296a4c3b691215260 SHA512 107a6df858c6bd2556ba4e86cc1922c3184df095f347039fa94bfd24e5ee21e1a4a9fba5a7cce248a06ad47f99978d9aae570efee7e30e165f33ea848a2cd3c3
+DIST samtools-1.19.2.tar.bz2 9150483 BLAKE2B fb845b2ccd61f1731ef4cdc180f4b9a4ac75e8c73c1ceaa9409b99e8052ca66b88c73fc71fd1067942aa24964f6df8dcb2d93631e5757e0cc200d7a3b9fad461 SHA512 c08d729fed21112855e0acc9cf7f29c7670d38a02ad6b0f2e9b9ef15a18f07e3e194cc4f6913481c98cd3e85dd4dc975dac96155b892da58bbe8ea3679a5270f
diff --git a/sci-biology/samtools/samtools-1.19.2.ebuild b/sci-biology/samtools/samtools-1.19.2.ebuild
new file mode 100644
index 000000000000..42879b0f8698
--- /dev/null
+++ b/sci-biology/samtools/samtools-1.19.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utilities for analysing and manipulating the SAM/BAM alignment formats"
+HOMEPAGE="http://www.htslib.org/"
+SRC_URI="https://github.com/samtools/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ =sci-libs/htslib-$(ver_cut 1-2)*:=
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # remove bundled htslib
+ rm -r htslib-* || die
+}
+
+src_configure() {
+ econf \
+ --with-ncurses \
+ --with-htslib=system \
+ CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw || die)"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+}