summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2017-12-18 13:54:36 +0000
committerJustin Lecher <jlec@gentoo.org>2017-12-18 14:03:48 +0000
commit684103b35a168b0c28229780d651f10aed1652da (patch)
tree1d758fe6f13e9d477b9c059825c122b789925131 /sci-chemistry/tinker/files
parentsys-cluster/charm: Fix for new rpc situation (diff)
downloadgentoo-684103b35a168b0c28229780d651f10aed1652da.tar.gz
gentoo-684103b35a168b0c28229780d651f10aed1652da.tar.bz2
gentoo-684103b35a168b0c28229780d651f10aed1652da.zip
sci-chemistry/tinker: Version Bump
Closes: https://bugs.gentoo.org/640608 Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-chemistry/tinker/files')
-rw-r--r--sci-chemistry/tinker/files/7.1.2-openmp.patch15
-rw-r--r--sci-chemistry/tinker/files/8.2.1-openmp.patch18
-rw-r--r--sci-chemistry/tinker/files/tinker-7.1.2-build.patch17
3 files changed, 18 insertions, 32 deletions
diff --git a/sci-chemistry/tinker/files/7.1.2-openmp.patch b/sci-chemistry/tinker/files/7.1.2-openmp.patch
deleted file mode 100644
index f3e8e2932b4a..000000000000
--- a/sci-chemistry/tinker/files/7.1.2-openmp.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/source/initial.f b/source/initial.f
-index 835f228..4099c74 100644
---- a/source/initial.f
-+++ b/source/initial.f
-@@ -73,8 +73,8 @@ c
- c
- c Intel compiler extensions to OpenMP standard
- c
--!$ call kmp_set_stacksize_s (2**28)
--!$ call kmp_set_blocktime (0)
-+! call kmp_set_stacksize_s (2**28)
-+! call kmp_set_blocktime (0)
- c
- c values of machine precision constants
- c
diff --git a/sci-chemistry/tinker/files/8.2.1-openmp.patch b/sci-chemistry/tinker/files/8.2.1-openmp.patch
new file mode 100644
index 000000000000..17199f9d4cfa
--- /dev/null
+++ b/sci-chemistry/tinker/files/8.2.1-openmp.patch
@@ -0,0 +1,18 @@
+ source/initial.f | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/source/initial.f b/source/initial.f
+index ff6ed54..9769a81 100644
+--- a/initial.f
++++ b/initial.f
+@@ -85,8 +85,8 @@ c
+ c Intel compiler extensions to OpenMP standard, 268435456 bytes is
+ c 2**28 bytes, or 256 MB; comment these lines for other compilers
+ c
+-c!$ call kmp_set_stacksize_s (268435456)
+-c!$ call kmp_set_blocktime (0)
++!$ call kmp_set_stacksize_s (268435456)
++!$ call kmp_set_blocktime (0)
+ c
+ c values of machine precision constants
+ c
diff --git a/sci-chemistry/tinker/files/tinker-7.1.2-build.patch b/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
deleted file mode 100644
index d6ef484b19a4..000000000000
--- a/sci-chemistry/tinker/files/tinker-7.1.2-build.patch
+++ /dev/null
@@ -1,17 +0,0 @@
- make/Makefile | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/make/Makefile b/make/Makefile
-index 61d5037..9be384a 100644
---- a/make/Makefile
-+++ b/make/Makefile
-@@ -719,8 +719,7 @@ EXEFILES = alchemy.x \
- %.x: %.o libtinker.a
- ${F77} ${LINKFLAGS} -o $@ $^ ${LIBS}; strip $@
-
--all:
-- ${EXEFILES}
-+all: ${EXEFILES}
-
- install:
- rename