summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-14 11:30:11 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-14 11:30:22 -0600
commit81bed4a1ecf90b8bc4e42a5abd9ff665282b0af2 (patch)
treef3974c2092072b0262366b8acb7560c53e7922e3 /sci-chemistry
parentsci-chemistry/votca-csgapps: fix deps (diff)
downloadgentoo-81bed4a1ecf90b8bc4e42a5abd9ff665282b0af2.tar.gz
gentoo-81bed4a1ecf90b8bc4e42a5abd9ff665282b0af2.tar.bz2
gentoo-81bed4a1ecf90b8bc4e42a5abd9ff665282b0af2.zip
sci-chemistry/votca-csgapps: import live ebuild from sci
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/votca-csgapps/votca-csgapps-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-chemistry/votca-csgapps/votca-csgapps-9999.ebuild b/sci-chemistry/votca-csgapps/votca-csgapps-9999.ebuild
new file mode 100644
index 000000000000..cb7b9cc9e783
--- /dev/null
+++ b/sci-chemistry/votca-csgapps/votca-csgapps-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit cmake-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Extra applications for votca-csg"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="~sci-chemistry/${PN%apps}-${PV}"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README )