summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-09-21 22:58:56 +0200
committerMatt Turner <mattst88@gentoo.org>2022-09-30 13:08:30 -0400
commit427dfb07f2974a289133c71d96a1ef37682fadcb (patch)
tree45aa58c26a46c950e0df884e0ca9bbd9d30dd2c7 /sci-geosciences/gnome-maps
parentmail-client/evolution: Version bump to 3.46.0 (diff)
downloadgentoo-427dfb07f2974a289133c71d96a1ef37682fadcb.tar.gz
gentoo-427dfb07f2974a289133c71d96a1ef37682fadcb.tar.bz2
gentoo-427dfb07f2974a289133c71d96a1ef37682fadcb.zip
sci-geosciences/gnome-maps: version bump to 43.0
meson.build says it depends on librest-1.0.0 but in reality depends on librest-0.9.1. 0.9.1 is newer than 1.0.0 Closes: https://github.com/gentoo/gentoo/pull/27383 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sci-geosciences/gnome-maps')
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-43.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index d56985966558..34e2c345f3b7 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1 +1,2 @@
DIST gnome-maps-42.3.tar.xz 2317328 BLAKE2B 365eb5cb8f7b20e2069338249418f5fad1abd47a1ab7ecda2d671dc97dfa45fb9f5687ae01fd605613c7ecf6eb9048aef6ab121cac0f455a42df9156581c87e2 SHA512 e52509603914de8f345a874f931beb68d11f718827b956a48464fe804c42559d977eacb0bbd5d4346b6329ab3f9169ac9afa8ef681f040c5b6a82b440b9786cb
+DIST gnome-maps-43.0.tar.xz 2330656 BLAKE2B 117a3558e29abe6a1bd29cf347b20a9e33f2b1cabd5310f28e387685e0bde96d1ce371c88616914f298e25ffbbc72b4d29e4fa721994b184e88289c6d0236ea0 SHA512 70966d6a092a67eb6a3a62627666376a71767d9296e00489a5aff281793425d9edd5e978deaf47bbd7d6b0ce37b53cf724b73487e101554c7984456661e193fc
diff --git a/sci-geosciences/gnome-maps/gnome-maps-43.0.ebuild b/sci-geosciences/gnome-maps/gnome-maps-43.0.ebuild
new file mode 100644
index 000000000000..441b75f62e73
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-43.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ x11-libs/pango[introspection]
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1
+ <dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0=[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/clutter-gtk:1.0[introspection]
+ media-libs/clutter:1.0[introspection]
+ net-libs/gnome-online-accounts[introspection]
+ net-libs/libgfbgraph[introspection]
+ net-libs/libsoup:3.0[introspection]
+ net-libs/webkit-gtk:4.1[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}