summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2018-01-06 13:32:31 +0000
committerJustin Lecher <jlec@gentoo.org>2018-01-06 13:35:38 +0000
commit1240b9e786d0f04d981e0e81c0a987579bc3ccf0 (patch)
treefd757d596154529c9f0e647afce17cb2a0abd50d /sci-libs/blas-reference
parentdev-tcltk/tktreectrl: Bump to EAPI=6 (diff)
downloadgentoo-1240b9e786d0f04d981e0e81c0a987579bc3ccf0.tar.gz
gentoo-1240b9e786d0f04d981e0e81c0a987579bc3ccf0.tar.bz2
gentoo-1240b9e786d0f04d981e0e81c0a987579bc3ccf0.zip
sci-libs/blas-reference: Fix test phase
Signed-off-by: Justin Lecher <jlec@gentoo.org> Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'sci-libs/blas-reference')
-rw-r--r--sci-libs/blas-reference/blas-reference-20151113-r1.ebuild7
-rw-r--r--sci-libs/blas-reference/blas-reference-20161223.ebuild7
2 files changed, 12 insertions, 2 deletions
diff --git a/sci-libs/blas-reference/blas-reference-20151113-r1.ebuild b/sci-libs/blas-reference/blas-reference-20151113-r1.ebuild
index 274ff2078119..03c812085216 100644
--- a/sci-libs/blas-reference/blas-reference-20151113-r1.ebuild
+++ b/sci-libs/blas-reference/blas-reference-20151113-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,6 +54,11 @@ src_compile() {
cmake-utils_src_compile -C BLAS
}
+src_test() {
+ local BUILD_DIR="${WORKDIR}/${P}_build/BLAS"
+ cmake-utils_src_test
+}
+
src_install() {
cmake-utils_src_install -C BLAS
diff --git a/sci-libs/blas-reference/blas-reference-20161223.ebuild b/sci-libs/blas-reference/blas-reference-20161223.ebuild
index 65ef230c1372..d896c2676773 100644
--- a/sci-libs/blas-reference/blas-reference-20161223.ebuild
+++ b/sci-libs/blas-reference/blas-reference-20161223.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -54,6 +54,11 @@ src_compile() {
cmake-utils_src_compile -C BLAS
}
+src_test() {
+ local BUILD_DIR="${WORKDIR}/${P}_build/BLAS"
+ cmake-utils_src_test
+}
+
src_install() {
cmake-utils_src_install -C BLAS