summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-03-23 16:40:44 +1100
committerSam Jorna <wraeth@gentoo.org>2016-03-23 16:43:39 +1100
commit01118e42ad7f531ffa1d85770fc9eb727b9918ea (patch)
tree678c3ed2b9374d9138596b92080ee43e5e816254 /sci-libs/geos/files
parentapp-emulation/qemu: backport various upstream fixes (diff)
downloadgentoo-01118e42ad7f531ffa1d85770fc9eb727b9918ea.tar.gz
gentoo-01118e42ad7f531ffa1d85770fc9eb727b9918ea.tar.bz2
gentoo-01118e42ad7f531ffa1d85770fc9eb727b9918ea.zip
sci-libs/geos: add python setup, fix php support
This adds python package setup per request, also fixes PHP support and restricts building against php-7 while unsupported. Gentoo-bug: 576436 Package-Manager: portage-2.2.28 Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'sci-libs/geos/files')
-rw-r--r--sci-libs/geos/files/geos-3.5.0-phpconfig-path.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-libs/geos/files/geos-3.5.0-phpconfig-path.patch b/sci-libs/geos/files/geos-3.5.0-phpconfig-path.patch
new file mode 100644
index 000000000000..b44eb9da9ea1
--- /dev/null
+++ b/sci-libs/geos/files/geos-3.5.0-phpconfig-path.patch
@@ -0,0 +1,29 @@
+diff --git a/php/Makefile.am b/php/Makefile.am
+index 5b50c0f..fad05c0 100644
+--- a/php/Makefile.am
++++ b/php/Makefile.am
+@@ -56,7 +56,7 @@ geos_la_CPPFLAGS = $(AM_CPPFLAGS) \
+ -I$(top_srcdir)/include
+
+ install: all
+- $(INSTALL) -d "$(DESTDIR)"/`$(PHP_CONFIG) --extension-dir`
+- $(INSTALL) -m 755 .libs/geos.so "$(DESTDIR)"/`php-config --extension-dir`
++ $(INSTALL) -d "$(DESTDIR)"`$(PHP_CONFIG) --extension-dir`
++ $(INSTALL) -m 755 .libs/geos.so "$(DESTDIR)"`$(PHP_CONFIG) --extension-dir`
+
+ endif
+diff --git a/php/Makefile.in b/php/Makefile.in
+index d8c343e..9485d0d 100644
+--- a/php/Makefile.in
++++ b/php/Makefile.in
+@@ -877,8 +877,8 @@ uninstall-am: uninstall-pkglibLTLIBRARIES
+
+
+ @ENABLE_PHP_TRUE@install: all
+-@ENABLE_PHP_TRUE@ $(INSTALL) -d "$(DESTDIR)"/`$(PHP_CONFIG) --extension-dir`
+-@ENABLE_PHP_TRUE@ $(INSTALL) -m 755 .libs/geos.so "$(DESTDIR)"/`php-config --extension-dir`
++@ENABLE_PHP_TRUE@ $(INSTALL) -d "$(DESTDIR)"`$(PHP_CONFIG) --extension-dir`
++@ENABLE_PHP_TRUE@ $(INSTALL) -m 755 .libs/geos.so "$(DESTDIR)"`$(PHP_CONFIG) --extension-dir`
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.