summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 19:03:26 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-15 19:04:56 +0200
commit9b498d0b2141ab6a8eb7436be15d993213e34996 (patch)
treec3c1490be915af03f6791bbee22469fb7affed14 /sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild
parentsci-libs/libgeodecomp: Rollover ~ppc keyword from 0.3.1 (diff)
downloadgentoo-9b498d0b2141ab6a8eb7436be15d993213e34996.tar.gz
gentoo-9b498d0b2141ab6a8eb7436be15d993213e34996.tar.bz2
gentoo-9b498d0b2141ab6a8eb7436be15d993213e34996.zip
sci-libs/libgeodecomp: Drop 0.3.1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild')
-rw-r--r--sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild b/sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild
deleted file mode 100644
index 739df1ee915c..000000000000
--- a/sci-libs/libgeodecomp/libgeodecomp-0.3.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit cmake-utils
-
-DESCRIPTION="An auto-parallelizing library to speed up computer simulations"
-HOMEPAGE="http://www.libgeodecomp.org"
-SRC_URI="http://www.libgeodecomp.org/archive/${P}.tar.bz2"
-
-SLOT="0"
-LICENSE="Boost-1.0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc examples"
-
-RDEPEND=">=dev-libs/boost-1.48"
-DEPEND="${RDEPEND}
- dev-libs/libflatarray
- examples? ( !sys-cluster/mpich2 )"
-
-S="${WORKDIR}/${P}/src"
-PATCHES=( "${FILESDIR}/libflatarray.patch" )
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -i 's/libdir=${CMAKE_INSTALL_PREFIX}\/lib/libdir=\/usr\/'$(get_libdir)'/' "${S}/CMakeLists.txt"
- sed -i 's/install(TARGETS geodecomp DESTINATION lib)/install(TARGETS geodecomp DESTINATION '$(get_libdir)')/' "${S}/CMakeLists.txt"
-
- if ! use examples ; then
- sed -i 's/examples//g' CMakeLists.txt
- fi
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_make doc
-}
-
-src_install() {
- DOCS=( ../README )
- use doc && HTML_DOCS=( ../doc/html/* )
- cmake-utils_src_install
-}
-
-src_test() {
- cmake-utils_src_make test
-}