summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-29 14:34:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-29 14:52:51 +0200
commit4f352e7b4f4394f5b3cac1084d73011421401c52 (patch)
tree1b9737f06764ea94fdd394a368f6e2e65c8316e7 /sci-libs/octomap/octomap-1.6.8.ebuild
parentdev-python/rospkg: bump to 1.0.41 (diff)
downloadgentoo-4f352e7b4f4394f5b3cac1084d73011421401c52.tar.gz
gentoo-4f352e7b4f4394f5b3cac1084d73011421401c52.tar.bz2
gentoo-4f352e7b4f4394f5b3cac1084d73011421401c52.zip
sci-libs/octomap: remove old
Package-Manager: portage-2.3.1
Diffstat (limited to 'sci-libs/octomap/octomap-1.6.8.ebuild')
-rw-r--r--sci-libs/octomap/octomap-1.6.8.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/sci-libs/octomap/octomap-1.6.8.ebuild b/sci-libs/octomap/octomap-1.6.8.ebuild
deleted file mode 100644
index 11055fe7732b..000000000000
--- a/sci-libs/octomap/octomap-1.6.8.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-SCM=""
-if [ "${PV#9999}" != "${PV}" ] ; then
- SCM="git-r3"
- EGIT_REPO_URI="https://github.com/OctoMap/octomap"
-fi
-
-inherit ${SCM} cmake-utils
-
-if [ "${PV#9999}" != "${PV}" ] ; then
- KEYWORDS=""
- SRC_URI=""
-else
- KEYWORDS="~amd64 ~arm"
- SRC_URI="https://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
-HOMEPAGE="http://octomap.github.io/"
-IUSE="qt4 dynamicEDT3D doc"
-LICENSE="BSD qt4? ( GPL-2 )"
-SLOT="0"
-
-RDEPEND="
- qt4? (
- virtual/opengl
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- x11-libs/libQGLViewer
- )
-"
-DEPEND="${RDEPEND}
- doc? (
- app-doc/doxygen
- media-gfx/graphviz
- )
-"
-
-src_prepare() {
- sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
- -i */CMakeLists.txt \
- -i */CMakeModules/InstallPkgConfigFile.cmake || die
- cmake-utils_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=(
- "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt4 ON OFF)"
- "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- if use doc ; then
- cd "${BUILD_DIR}/octomap"
- emake docs
- if use dynamicEDT3D ; then
- cd "${BUILD_DIR}/dynamicEDT3D"
- emake docs_dynamicEDT3D
- fi
- fi
-}
-
-src_install() {
- cmake-utils_src_install
- if use doc ; then
- insinto /usr/share/doc/${PF}/html/octomap
- doins -r "${S}/octomap/doc/html/"*
- if use dynamicEDT3D ; then
- insinto /usr/share/doc/${PF}/html/dynamicEDT3D
- doins -r "${S}/dynamicEDT3D/doc/html/"*
- fi
- fi
-}