summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2024-06-29 12:04:22 -0400
committerMichael Orlitzky <mjo@gentoo.org>2024-06-29 12:07:36 -0400
commita19d7547d47610a5957bba714abdf8374365ce6c (patch)
tree93266b01713236adcca530124592435bf4844162 /sci-libs
parentdev-python/jaraco-test: keyword 5.4.0 for ~mips (diff)
downloadgentoo-a19d7547d47610a5957bba714abdf8374365ce6c.tar.gz
gentoo-a19d7547d47610a5957bba714abdf8374365ce6c.tar.bz2
gentoo-a19d7547d47610a5957bba714abdf8374365ce6c.zip
sci-libs/m4ri: upstream patch for bad tests
Closes: https://bugs.gentoo.org/908449 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/m4ri/files/m4ri-20200125-testfix.patch31
-rw-r--r--sci-libs/m4ri/m4ri-20200125.ebuild4
2 files changed, 34 insertions, 1 deletions
diff --git a/sci-libs/m4ri/files/m4ri-20200125-testfix.patch b/sci-libs/m4ri/files/m4ri-20200125-testfix.patch
new file mode 100644
index 000000000000..cd45acac4d69
--- /dev/null
+++ b/sci-libs/m4ri/files/m4ri-20200125-testfix.patch
@@ -0,0 +1,31 @@
+From 0643268f316af1150ea2631d27fd1533f5994bb8 Mon Sep 17 00:00:00 2001
+From: "Martin R. Albrecht" <martinralbrecht@googlemail.com>
+Date: Wed, 6 May 2020 13:15:44 +0100
+Subject: [PATCH] don't test things we forbid
+
+fixes #75
+---
+ tests/test_misc.c | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/tests/test_misc.c b/tests/test_misc.c
+index b1a2e32..0ccddb3 100644
+--- a/tests/test_misc.c
++++ b/tests/test_misc.c
+@@ -130,11 +130,11 @@ int main(int argc, char *argv[]) {
+ status += test_submatrix(2, 130, 1, 1, 2, 130);
+ status += test_submatrix(2, 131, 1, 1, 2, 131);
+
+- status += test_submatrix(2, 63, 1, 1, 1, 63);
+- status += test_submatrix(2, 64, 1, 1, 1, 64);
+- status += test_submatrix(2, 65, 1, 1, 1, 65);
+- status += test_submatrix(2, 66, 1, 1, 1, 66);
+- status += test_submatrix(2, 67, 1, 1, 1, 67);
++ status += test_submatrix(2, 63, 1, 1, 2, 63);
++ status += test_submatrix(2, 64, 1, 1, 2, 64);
++ status += test_submatrix(2, 65, 1, 1, 2, 65);
++ status += test_submatrix(2, 66, 1, 1, 2, 66);
++ status += test_submatrix(2, 67, 1, 1, 2, 67);
+
+ status += test_submatrix(2, 127, 1, 63, 2, 127);
+ status += test_submatrix(2, 128, 1, 64, 2, 128);
diff --git a/sci-libs/m4ri/m4ri-20200125.ebuild b/sci-libs/m4ri/m4ri-20200125.ebuild
index adf6e85765c9..5c4de4a39ebf 100644
--- a/sci-libs/m4ri/m4ri-20200125.ebuild
+++ b/sci-libs/m4ri/m4ri-20200125.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,6 +18,8 @@ BDEPEND="virtual/pkgconfig"
DEPEND="png? ( media-libs/libpng:= )"
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}/${P}-testfix.patch" )
+
# NEWS and ChangeLog are empty as of 2020-01-01, and README.md
# didn't make it into the release tarball.
DOCS=( AUTHORS )