summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-mathematics/topcom/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-mathematics/topcom/files')
-rw-r--r--sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch105
-rw-r--r--sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch77
2 files changed, 182 insertions, 0 deletions
diff --git a/sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch b/sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch
new file mode 100644
index 000000000000..e8546aa846dc
--- /dev/null
+++ b/sci-mathematics/topcom/files/topcom-0.17.4-buildsystem.patch
@@ -0,0 +1,105 @@
+ lib-src-reg/Makefile.am | 8 +++-----
+ lib-src/Makefile.am | 8 +++-----
+ src-reg/Makefile.am | 12 +++++-------
+ src/Makefile.am | 12 +++++-------
+ wrap-gmp-gmpxx/Makefile.am | 2 +-
+ 5 files changed, 17 insertions(+), 25 deletions(-)
+
+diff --git a/lib-src-reg/Makefile.am b/lib-src-reg/Makefile.am
+index 67c1dc9..202d6fa 100644
+--- a/lib-src-reg/Makefile.am
++++ b/lib-src-reg/Makefile.am
+@@ -10,11 +10,9 @@ SPXinterface.hh \
+ RegularityCheck.hh \
+ LPinterface.hh
+
+-INCLUDES = -I../lib-src
+-INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
++INCLUDES = -I$(top_srcdir)/lib-src
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
++INCLUDES += -I$(top_srcdir)/external/include
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
+-
+-AM_CXXFLAGS = -O2
+diff --git a/lib-src/Makefile.am b/lib-src/Makefile.am
+index defed87..c94109c 100644
+--- a/lib-src/Makefile.am
++++ b/lib-src/Makefile.am
+@@ -88,11 +88,9 @@ VertexFacetTable.hh \
+ VertexFacetTableArray.hh \
+ VirtualChiro.hh
+
+-INCLUDES = -I../lib-src-reg
+-INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
++INCLUDES = -I$(top_srcdir)/lib-src-reg
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
++INCLUDES += -I$(top_srcdir)/external/include
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-35
+-
+-AM_CXXFLAGS = -O2 -g
+diff --git a/src-reg/Makefile.am b/src-reg/Makefile.am
+index b0219a5..e9b00bc 100644
+--- a/src-reg/Makefile.am
++++ b/src-reg/Makefile.am
+@@ -2,15 +2,13 @@ bin_PROGRAMS = checkregularity
+
+ checkregularity_SOURCES = checkregularity.cc
+
+-LDADD = ../lib-src-reg/libCHECKREG.a \
+- ../lib-src/libTOPCOM.a
++LDADD = $(top_builddir)/lib-src-reg/libCHECKREG.a \
++ $(top_builddir)/lib-src/libTOPCOM.a
+
+-INCLUDES = -I../lib-src
+-INCLUDES += -I../lib-src-reg
+-INCLUDES += -I../wrap-gmp-gmpxx
++INCLUDES = -I$(top_srcdir)/lib-src
++INCLUDES += -I$(top_srcdir)/lib-src-reg
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
+ INCLUDES += -I$(includedir)
+
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
+-
+-AM_CXXFLAGS = -O2
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 5ba9b22..4c59202 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -85,14 +85,12 @@ santos_triang_SOURCES = santos_triang.cc
+ santos_dim4_triang_SOURCES = santos_dim4_triang.cc
+ santos_22_triang_SOURCES = santos_22_triang.cc
+
+-LDADD = ../lib-src/libTOPCOM.a \
+- ../lib-src-reg/libCHECKREG.a
++LDADD = $(top_builddir)/lib-src/libTOPCOM.a \
++ $(top_builddir)/lib-src-reg/libCHECKREG.a
+
+-INCLUDES = -I../lib-src
+-INCLUDES += -I../lib-src-reg
+-INCLUDES += -I../wrap-gmp-gmpxx
++INCLUDES = -I$(top_srcdir)/lib-src
++INCLUDES += -I$(top_srcdir)/lib-src-reg
++INCLUDES += -I$(top_srcdir)/wrap-gmp-gmpxx
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30
+-
+-AM_CXXFLAGS = -O2
+diff --git a/wrap-gmp-gmpxx/Makefile.am b/wrap-gmp-gmpxx/Makefile.am
+index 383e003..d93a637 100644
+--- a/wrap-gmp-gmpxx/Makefile.am
++++ b/wrap-gmp-gmpxx/Makefile.am
+@@ -2,5 +2,5 @@ include_HEADERS = \
+ Integer.h \
+ Rational.h
+
+-INCLUDES = -I../external/include
++INCLUDES = -I$(top_srcdir)/external/include
+ INCLUDES += -I$(includedir)
diff --git a/sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch b/sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch
new file mode 100644
index 000000000000..e9cffeec7440
--- /dev/null
+++ b/sci-mathematics/topcom/files/topcom-0.17.4-no-internal-libs.patch
@@ -0,0 +1,77 @@
+ Makefile.am | 4 ----
+ configure.ac | 6 +-----
+ src-reg/Makefile.am | 6 +-----
+ src/Makefile.am | 6 +-----
+ 4 files changed, 3 insertions(+), 19 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 640652f..00ba26a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,2 @@
+ SUBDIRS = wrap-gmp-gmpxx lib-src-reg lib-src src-reg src examples
+ EXTRA_DIST = external/Makefile
+-EXTRA_DIST += external/gmp-5.0.5.tar.bz2
+-EXTRA_DIST += external/cddlib-0.94f-TOPCOM.tar.gz
+-EXTRA_DIST += external/gmpxx-patch
+-
+diff --git a/configure.ac b/configure.ac
+index b737f27..ecd38ce 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -17,12 +17,8 @@ dnl Replace `main' with a function in -lstdc:
+ dnl AC_CHECK_LIB(stdc, main)
+ dnl Replace `main' with a function in -lstdc++:
+ dnl AC_CHECK_LIB(stdc++, main)
+-dnl Make libgmp:
+-make -C external gmp
+-dnl Make libcddgmp:
+-make -C external cdd
+ dnl Check for soplex:
+-AC_CHECK_LIB(soplex, main, , csh -c 'echo soplex not found: --soplex will not work.')
++AC_CHECK_LIB(soplex, main, , sh -c 'echo soplex not found: --soplex will not work.')
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+diff --git a/src-reg/Makefile.am b/src-reg/Makefile.am
+index c976e34..b0219a5 100644
+--- a/src-reg/Makefile.am
++++ b/src-reg/Makefile.am
+@@ -3,15 +3,11 @@ bin_PROGRAMS = checkregularity
+ checkregularity_SOURCES = checkregularity.cc
+
+ LDADD = ../lib-src-reg/libCHECKREG.a \
+- ../lib-src/libTOPCOM.a \
+- ../external/lib/libcddgmp.a \
+- ../external/lib/libgmpxx.a \
+- ../external/lib/libgmp.a
++ ../lib-src/libTOPCOM.a
+
+ INCLUDES = -I../lib-src
+ INCLUDES += -I../lib-src-reg
+ INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
+ INCLUDES += -I$(includedir)
+
+
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 4c35135..5ba9b22 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -86,15 +86,11 @@ santos_dim4_triang_SOURCES = santos_dim4_triang.cc
+ santos_22_triang_SOURCES = santos_22_triang.cc
+
+ LDADD = ../lib-src/libTOPCOM.a \
+- ../lib-src-reg/libCHECKREG.a \
+- ../external/lib/libcddgmp.a \
+- ../external/lib/libgmpxx.a \
+- ../external/lib/libgmp.a
++ ../lib-src-reg/libCHECKREG.a
+
+ INCLUDES = -I../lib-src
+ INCLUDES += -I../lib-src-reg
+ INCLUDES += -I../wrap-gmp-gmpxx
+-INCLUDES += -I../external/include
+ INCLUDES += -I$(includedir)
+
+ AM_CPPFLAGS = -DVERBOSE -DGMPRATIONAL -ftemplate-depth-30