summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-07-15 01:27:57 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-07-15 02:26:37 +0200
commit52bc3f379b6f9d6d2fab531cd4b6240609e231ae (patch)
tree926d8ad71ffa002e3a36068bc82fbbdea43a7d93 /sci-mathematics
parentsci-electronics/nvc: bump to 1.10.0 (diff)
downloadgentoo-52bc3f379b6f9d6d2fab531cd4b6240609e231ae.tar.gz
gentoo-52bc3f379b6f9d6d2fab531cd4b6240609e231ae.tar.bz2
gentoo-52bc3f379b6f9d6d2fab531cd4b6240609e231ae.zip
sci-mathematics/vampire: bump to 4.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/vampire/Manifest1
-rw-r--r--sci-mathematics/vampire/vampire-4.8.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sci-mathematics/vampire/Manifest b/sci-mathematics/vampire/Manifest
index 87b78ccedb91..1432854a8700 100644
--- a/sci-mathematics/vampire/Manifest
+++ b/sci-mathematics/vampire/Manifest
@@ -1 +1,2 @@
DIST vampire-4.7.tar.gz 1462358 BLAKE2B 10fdf4076bbcd7113da575d19890634a5142dd6917c028eb7ae0e94405df9e6915fc6127956d39b6f9f97242958b0fa04fa9e835853f09cec381786862009ef5 SHA512 978169a9b4d561dce1d55aa9a61a8b302657ff758036309d9c5f58a5d9271b874ac020d110fbb2a16d34f2ccdd10a497eb469829c91d58530dba5e1cd8978d78
+DIST vampire-4.8-casc2023.tar.gz 1527236 BLAKE2B fb6ce26bb31996529e2b4d76173a1cb8d2c796aa6a5a2581515c516b5f07e9d4efc6040db1ac7f65388d723ee5080d62fb9c2b6ec88f58babd892fd96c0bf0ba SHA512 d6349ab23a289101a0d9f3caa5190df065dfbbe4e2e999e7d5b97ff738c8355b35848d93423ec3a0b0f88d4ac806173493f9a2de4e31945bb09c500c64eb5028
diff --git a/sci-mathematics/vampire/vampire-4.8.ebuild b/sci-mathematics/vampire/vampire-4.8.ebuild
new file mode 100644
index 000000000000..685a97060dca
--- /dev/null
+++ b/sci-mathematics/vampire/vampire-4.8.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic cmake
+
+DESCRIPTION="The Vampire Prover, theorem prover for first-order logic"
+HOMEPAGE="https://vprover.github.io/
+ https://github.com/vprover/vampire/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vprover/${PN}.git"
+ EGIT_SUBMODULES=()
+else
+ # v4.8casc2023 - "This is the 4.8 version submitted to CASC in 2023."
+ SRC_URI="https://github.com/vprover/${PN}/archive/v${PV}casc2023.tar.gz
+ -> ${P}-casc2023.tar.gz"
+ S="${WORKDIR}"/${PN}-${PV}casc2023
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE="debug +z3"
+# debug mode needs to be enabled for tests
+# https://github.com/vprover/vampire/blob/8197e1d2d86a0b276b5fcb6c02d8122f66b7277e/CMakeLists.txt#L38
+RESTRICT="!debug? ( test )"
+
+RDEPEND="
+ z3? (
+ dev-libs/gmp:=
+ >=sci-mathematics/z3-4.11.2:=
+ )
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # -Werror=strict-aliasing warnings, bug #863269
+ filter-lto
+ append-flags -fno-strict-aliasing
+
+ local CMAKE_BUILD_TYPE=$(usex debug Debug Release)
+
+ local -a mycmakeargs=(
+ -DZ3_DIR=$(usex z3 "/usr/$(get_libdir)/cmake/z3/" "")
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local bin_name=$(find "${BUILD_DIR}"/bin/ -type f -name "${PN}*")
+ exeinto /usr/bin
+ doexe "${bin_name}"
+ dosym $(basename "${bin_name}") /usr/bin/${PN}
+
+ einstalldocs
+}