summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-02-28 11:44:13 +0100
committerGuilherme Amadio <amadio@gentoo.org>2023-02-28 11:47:43 +0100
commita20cfd13e6d1730e14576ea02e412e38d34135ee (patch)
tree5cad1bdeed823aa184f037e6a5ea3bea88d19606 /sci-physics/root
parentmedia-gfx/darktable: squash -Werror in rawspeed (diff)
downloadgentoo-a20cfd13e6d1730e14576ea02e412e38d34135ee.tar.gz
gentoo-a20cfd13e6d1730e14576ea02e412e38d34135ee.tar.bz2
gentoo-a20cfd13e6d1730e14576ea02e412e38d34135ee.zip
sci-physics/root: rely on MYCMAKEARGS from cmake.eclass
Closes: https://bugs.gentoo.org/897900 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/root-6.26.08.ebuild5
-rw-r--r--sci-physics/root/root-6.26.9999.ebuild5
-rw-r--r--sci-physics/root/root-6.28.00.ebuild5
-rw-r--r--sci-physics/root/root-6.28.9999.ebuild5
-rw-r--r--sci-physics/root/root-9999.ebuild5
5 files changed, 10 insertions, 15 deletions
diff --git a/sci-physics/root/root-6.26.08.ebuild b/sci-physics/root/root-6.26.08.ebuild
index ec8f9983775c..c83e19af3636 100644
--- a/sci-physics/root/root-6.26.08.ebuild
+++ b/sci-physics/root/root-6.26.08.ebuild
@@ -139,9 +139,9 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
elog "There are extra options on packages not available in Gentoo."
- elog "You can use the environment variable EXTRA_ECONF to enable"
+ elog "You can use the environment variable MYCMAKEARGS to enable"
elog "these packages. For example, for Vdt you would set:"
- elog "EXTRA_ECONF=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
+ elog "MYCMAKEARGS=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
}
src_prepare() {
@@ -290,7 +290,6 @@ src_configure() {
-Dx11=$(usex X)
-Dxml=$(usex xml)
-Dxrootd=$(usex xrootd)
- "${EXTRA_ECONF}"
)
cmake_src_configure
diff --git a/sci-physics/root/root-6.26.9999.ebuild b/sci-physics/root/root-6.26.9999.ebuild
index ec8f9983775c..c83e19af3636 100644
--- a/sci-physics/root/root-6.26.9999.ebuild
+++ b/sci-physics/root/root-6.26.9999.ebuild
@@ -139,9 +139,9 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
elog "There are extra options on packages not available in Gentoo."
- elog "You can use the environment variable EXTRA_ECONF to enable"
+ elog "You can use the environment variable MYCMAKEARGS to enable"
elog "these packages. For example, for Vdt you would set:"
- elog "EXTRA_ECONF=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
+ elog "MYCMAKEARGS=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
}
src_prepare() {
@@ -290,7 +290,6 @@ src_configure() {
-Dx11=$(usex X)
-Dxml=$(usex xml)
-Dxrootd=$(usex xrootd)
- "${EXTRA_ECONF}"
)
cmake_src_configure
diff --git a/sci-physics/root/root-6.28.00.ebuild b/sci-physics/root/root-6.28.00.ebuild
index e25434a11de7..473a60acd759 100644
--- a/sci-physics/root/root-6.28.00.ebuild
+++ b/sci-physics/root/root-6.28.00.ebuild
@@ -143,9 +143,9 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
elog "There are extra options on packages not available in Gentoo."
- elog "You can use the environment variable EXTRA_ECONF to enable"
+ elog "You can use the environment variable MYCMAKEARGS to enable"
elog "these packages. For example, for Vdt you would set:"
- elog "EXTRA_ECONF=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
+ elog "MYCMAKEARGS=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
}
src_prepare() {
@@ -307,7 +307,6 @@ src_configure() {
-Dx11=$(usex X)
-Dxml=$(usex xml)
-Dxrootd=$(usex xrootd)
- "${EXTRA_ECONF}"
)
# Needs to be here, otherwise gets overriden by cmake.eclass
diff --git a/sci-physics/root/root-6.28.9999.ebuild b/sci-physics/root/root-6.28.9999.ebuild
index e25434a11de7..473a60acd759 100644
--- a/sci-physics/root/root-6.28.9999.ebuild
+++ b/sci-physics/root/root-6.28.9999.ebuild
@@ -143,9 +143,9 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
elog "There are extra options on packages not available in Gentoo."
- elog "You can use the environment variable EXTRA_ECONF to enable"
+ elog "You can use the environment variable MYCMAKEARGS to enable"
elog "these packages. For example, for Vdt you would set:"
- elog "EXTRA_ECONF=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
+ elog "MYCMAKEARGS=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
}
src_prepare() {
@@ -307,7 +307,6 @@ src_configure() {
-Dx11=$(usex X)
-Dxml=$(usex xml)
-Dxrootd=$(usex xrootd)
- "${EXTRA_ECONF}"
)
# Needs to be here, otherwise gets overriden by cmake.eclass
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index e25434a11de7..473a60acd759 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -143,9 +143,9 @@ pkg_setup() {
use python && python-single-r1_pkg_setup
elog "There are extra options on packages not available in Gentoo."
- elog "You can use the environment variable EXTRA_ECONF to enable"
+ elog "You can use the environment variable MYCMAKEARGS to enable"
elog "these packages. For example, for Vdt you would set:"
- elog "EXTRA_ECONF=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
+ elog "MYCMAKEARGS=\"-Dbuiltin_vdt=ON -Dvdt=ON\""
}
src_prepare() {
@@ -307,7 +307,6 @@ src_configure() {
-Dx11=$(usex X)
-Dxml=$(usex xml)
-Dxrootd=$(usex xrootd)
- "${EXTRA_ECONF}"
)
# Needs to be here, otherwise gets overriden by cmake.eclass