summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-05-09 16:48:22 +0200
committerDavid Seifert <soap@gentoo.org>2021-05-09 16:48:22 +0200
commitd4bf14fc886ff8638f3ad48855279376631ff423 (patch)
tree8112d45e93e2ae69813f428772f4b7479370e64d /sci-visualization/ggobi/files
parentnet-libs/nodejs: sync the live ebuild with v16 (diff)
downloadgentoo-d4bf14fc886ff8638f3ad48855279376631ff423.tar.gz
gentoo-d4bf14fc886ff8638f3ad48855279376631ff423.tar.bz2
gentoo-d4bf14fc886ff8638f3ad48855279376631ff423.zip
sci-visualization/ggobi: Respect CFLAGS
Closes: https://bugs.gentoo.org/741638 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-visualization/ggobi/files')
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch4
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch4
-rw-r--r--sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch29
3 files changed, 29 insertions, 8 deletions
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch b/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch
index 388cb85c975c..c41581e3c599 100644
--- a/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch
+++ b/sci-visualization/ggobi/files/ggobi-2.1.10-desktop.patch
@@ -1,5 +1,5 @@
---- xdg/ggobi.desktop.orig 2013-02-24 22:20:02.616872402 -0800
-+++ xdg/ggobi.desktop 2013-02-24 22:20:13.293924862 -0800
+--- a/xdg/ggobi.desktop
++++ b/xdg/ggobi.desktop
@@ -6,6 +6,6 @@
Comment=Multivariate interactive graphics for exploratory data analysis
TryExec=ggobi
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch b/sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch
index 0476f47a816d..bd831f61ce8a 100644
--- a/sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch
+++ b/sci-visualization/ggobi/files/ggobi-2.1.8-plugindir.patch
@@ -1,5 +1,5 @@
---- plugins/Makefile.plugin.orig 2009-12-14 22:15:01.000000000 +0000
-+++ plugins/Makefile.plugin 2009-12-14 22:15:16.000000000 +0000
+--- a/plugins/Makefile.plugin
++++ b/plugins/Makefile.plugin
@@ -2,7 +2,7 @@
# Every plugin provides a single library to GGobi, define it here.
diff --git a/sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch b/sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch
index 3bec9b55c21d..bc6ef01e4075 100644
--- a/sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch
+++ b/sci-visualization/ggobi/files/ggobi-2.1.9-as-needed.patch
@@ -1,5 +1,5 @@
---- configure.ac.orig 2012-06-26 05:46:07.000000000 +0100
-+++ configure.ac 2012-06-26 05:46:44.000000000 +0100
+--- a/configure.ac
++++ b/configure.ac
@@ -178,6 +178,8 @@
echo "Looking for gtk2"
@@ -10,8 +10,8 @@
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)
---- src/Makefile.am.orig 2012-06-26 04:53:20.000000000 +0100
-+++ src/Makefile.am 2012-06-26 04:54:04.000000000 +0100
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -4,7 +4,6 @@
libggobi_la_GOBHEADERS = $(libggobi_la_GOBS:%.gob=ggobi-%.h)
libggobi_la_GOBOBJECTS = $(libggobi_la_GOBS:%.gob=ggobi-%.lo)
@@ -38,3 +38,24 @@
ggobi_LDFLAGS = -mwindows -s
endif
+--- a/plugins/GraphLayout/configure.ac
++++ b/plugins/GraphLayout/configure.ac
+@@ -44,6 +44,7 @@
+ AC_MSG_RESULT(no)])
+
+ AC_MSG_CHECKING([whether Graphviz API is based on cgraph])
++save_CFLAGS="${CFLAGS}"
+ CFLAGS=$LIBGVC_CFLAGS
+ AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+ #include <gvc.h>
+@@ -53,8 +54,10 @@
+ return 0;
+ }
+ ])], graphviz_new_api=yes, graphviz_new_api=no)
++CFLAGS="${save_CFLAGS}"
+ AC_MSG_RESULT($graphviz_new_api)
+ if test "$graphviz_new_api" = "yes"; then
++ CFLAGS="${CFLAGS} ${LIBGVC_CFLAGS}"
+ AC_DEFINE(HAVE_CGRAPH,[1],[define for cgraph-based graphviz])
+ fi
+