summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2020-12-16 18:37:44 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-12-16 18:46:35 +0100
commit11ef12911eb659281901d8a5913ffdcfe250d157 (patch)
treef7216b8637e4be52bb1a7135351d099893458252 /sys-apps/kbd
parentdev-python/ebuildtester: Adding sys-fs/fuse dep (diff)
downloadgentoo-11ef12911eb659281901d8a5913ffdcfe250d157.tar.gz
gentoo-11ef12911eb659281901d8a5913ffdcfe250d157.tar.bz2
gentoo-11ef12911eb659281901d8a5913ffdcfe250d157.zip
sys-apps/kbd: Bump to version 2.4.0
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/Manifest1
-rw-r--r--sys-apps/kbd/kbd-2.4.0.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/sys-apps/kbd/Manifest b/sys-apps/kbd/Manifest
index 42f2396f56a2..2e198b9ba9f2 100644
--- a/sys-apps/kbd/Manifest
+++ b/sys-apps/kbd/Manifest
@@ -1,3 +1,4 @@
DIST kbd-2.0.4.tar.xz 1031864 BLAKE2B 10c2bded89befda1f1d7ab199796e082a4e3b2333cf29a2abbbe843191dce41a7289d5bc3b7e55d8b25c7144ae4b4977e4321b38896917d0083af8ddd4924a3e SHA512 5e264b3695b0af0bc85e0a4fa2c43e13648d8ea82102f3b051c28da2abfc52977577c470bce48f30cec9b0d215297e48c9b05e00561c990e3770fb68f6544e0f
DIST kbd-2.2.0.tar.xz 1115220 BLAKE2B d4218f3a8f9212d16e8a14011f0e136f6aebd18f13f8d5da2bd63296e0aa857fc5e7fe927200345fca3b723bc879f87511b02c152824a73ae5743cc8175991e6 SHA512 5f407c20739487e423e8390e429d30838a1a69a0a50db083803ce56da919e25ce480b63fd1bcfac9eb362095f17e575783b09eaa55e26b442bfa3ed838e04f13
DIST kbd-2.3.0.tar.xz 1099660 BLAKE2B 20044b942cc2568acc9c4616bc38cc0bacb6773ba397327e9e23c87f0473cfdb1a165b9905039fc60b69001d99f799c48491ca098b64961cf5821f7d4b954df7 SHA512 6d7ba496a963c29abf1f514831c47e6bc73797b04021115879cbdb203c879c5abfae9f8fcaeec52d8891cad848240d39f5293452d26c7f0a84fb58499ad6e927
+DIST kbd-2.4.0.tar.xz 1120700 BLAKE2B aa5fc1067d3414b9fa18f35dd81dcc050cdf10bd8692221b6e5304e94c4f90055386ce1f79d2bd092241f9ce15ffd36d5c00d1a15725166d16183f475be4a2e3 SHA512 c3823e40878ed4cb5b90edf753dba37a7fc3189b7b08a2e59a7830cac23a7a7daf31dedef1fcc130698c7508bc2a037c8ab54e749d0cdbf51756e346f2ed5abb
diff --git a/sys-apps/kbd/kbd-2.4.0.ebuild b/sys-apps/kbd/kbd-2.4.0.ebuild
new file mode 100644
index 000000000000..ef571616a3ab
--- /dev/null
+++ b/sys-apps/kbd/kbd-2.4.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit autotools git-r3
+ #EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
+ EGIT_REPO_URI="https://github.com/legionus/kbd.git"
+ EGIT_BRANCH="master"
+else
+ if [[ $(ver_cut 3) -lt 90 ]] ; then
+ SRC_URI="https://www.kernel.org/pub/linux/utils/kbd/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ else
+ inherit autotools
+ SRC_URI="https://github.com/legionus/kbd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ fi
+fi
+
+DESCRIPTION="Keyboard and console utilities"
+HOMEPAGE="http://kbd-project.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls pam test"
+#RESTRICT="!test? ( test )"
+# Upstream has strange assumptions how to run tests (see bug #732868)
+RESTRICT="test"
+
+RDEPEND="
+ app-arch/gzip
+ pam? (
+ !app-misc/vlock
+ sys-libs/pam
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ test? ( dev-libs/check )
+"
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ git-r3_src_unpack
+ else
+ default
+ fi
+
+ # Rename conflicting keymaps to have unique names, bug #293228
+ cd "${S}"/data/keymaps/i386 || die
+ mv fgGIod/trf.map fgGIod/trf-fgGIod.map || die
+ mv olpc/es.map olpc/es-olpc.map || die
+ mv olpc/pt.map olpc/pt-olpc.map || die
+ mv qwerty/cz.map qwerty/cz-qwerty.map || die
+}
+
+src_prepare() {
+ default
+ if [[ ${PV} == "9999" ]] || [[ $(ver_cut 3) -ge 90 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ # USE="test" installs .a files
+ --disable-static
+ $(use_enable nls)
+ $(use_enable pam vlock)
+ $(use_enable test tests)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ docinto html
+ dodoc docs/doc/*.html
+
+ # USE="test" installs .la files
+ find "${ED}" -type f -name "*.la" -delete || die
+}