summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 18:46:31 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 18:48:00 +0100
commit7f49b03487c42918e64e98e064ee20d8316a70cd (patch)
treea49b3e8f10a1de169c144c9504418eb41bcb71ea /sys-apps/pkgcore
parentdev-python/snakeoil: Bump to 0.9.9 (diff)
downloadgentoo-7f49b03487c42918e64e98e064ee20d8316a70cd.tar.gz
gentoo-7f49b03487c42918e64e98e064ee20d8316a70cd.tar.bz2
gentoo-7f49b03487c42918e64e98e064ee20d8316a70cd.zip
sys-apps/pkgcore: Bump to 0.12.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-apps/pkgcore')
-rw-r--r--sys-apps/pkgcore/Manifest1
-rw-r--r--sys-apps/pkgcore/pkgcore-0.12.9.ebuild50
-rw-r--r--sys-apps/pkgcore/pkgcore-9999.ebuild2
3 files changed, 52 insertions, 1 deletions
diff --git a/sys-apps/pkgcore/Manifest b/sys-apps/pkgcore/Manifest
index 836646496b28..791a2c4a80a7 100644
--- a/sys-apps/pkgcore/Manifest
+++ b/sys-apps/pkgcore/Manifest
@@ -1 +1,2 @@
DIST pkgcore-0.12.8.tar.gz 624442 BLAKE2B d7e15fc659820e3cd6e4f7848413c12b2439d38900c9f64c582ba078d3fe874c12d66d39fdf59a7e4ff585d82d29fcad16c9af869b2388ed6e0af0be7d16d887 SHA512 d02087d4bada3bc2f87738b0ddedc72782b2facdf681927e84fed32dc6645e48ebde83de5aeb9eb0f64e01afe2ac511ae0f7450a2708698bbad872a60044319b
+DIST pkgcore-0.12.9.tar.gz 624918 BLAKE2B 190ccae01862b7e498dabcab5e8716ab0f3ed732eeb0469a0ca39f5e201c75ea19575f49be29a6d36b3acad8d5252528dc5e76444cd21fec25681a9350b93875 SHA512 2e391f9ae2baacaaec025c4b6cd7fd7c7757d7815d8bc62aec0f09e4fdbf7fc99ce832bc2c3ce15013fda860465ca19f27377935dc535a286446e548e08be6cd
diff --git a/sys-apps/pkgcore/pkgcore-0.12.9.ebuild b/sys-apps/pkgcore/pkgcore-0.12.9.ebuild
new file mode 100644
index 000000000000..bf0996ccbaa8
--- /dev/null
+++ b/sys-apps/pkgcore/pkgcore-0.12.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+
+RDEPEND="
+ >=app-shells/bash-5.0
+ dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+ RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+ RDEPEND+=" >=dev-python/snakeoil-0.9.6[${PYTHON_USEDEP}]"
+fi
+BDEPEND="
+ test? (
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_test() {
+ local -x PYTHONDONTWRITEBYTECODE=
+ distutils-r1_src_test
+}
+
+python_install_all() {
+ local DOCS=( NEWS.rst )
+ [[ ${PV} == *9999 ]] || doman man/*
+ distutils-r1_python_install_all
+}
diff --git a/sys-apps/pkgcore/pkgcore-9999.ebuild b/sys-apps/pkgcore/pkgcore-9999.ebuild
index 5c7eeb03645d..bf0996ccbaa8 100644
--- a/sys-apps/pkgcore/pkgcore-9999.ebuild
+++ b/sys-apps/pkgcore/pkgcore-9999.ebuild
@@ -11,7 +11,7 @@ if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
fi