summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-10 14:54:04 +0000
committerSam James <sam@gentoo.org>2021-01-10 14:54:55 +0000
commitf327534e8ce5e8789495fa46d60d18eeb5f8071c (patch)
treeacbcba8d88b72b958708678015fffdfeb934b53b /sys-apps/toybox/toybox-0.8.4.ebuild
parentdev-python/setproctitle: Remove old (diff)
downloadgentoo-f327534e8ce5e8789495fa46d60d18eeb5f8071c.tar.gz
gentoo-f327534e8ce5e8789495fa46d60d18eeb5f8071c.tar.bz2
gentoo-f327534e8ce5e8789495fa46d60d18eeb5f8071c.zip
sys-apps/toybox: bump to 0.8.4
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/toybox/toybox-0.8.4.ebuild')
-rw-r--r--sys-apps/toybox/toybox-0.8.4.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-apps/toybox/toybox-0.8.4.ebuild b/sys-apps/toybox/toybox-0.8.4.ebuild
new file mode 100644
index 000000000000..6abff1d6eb86
--- /dev/null
+++ b/sys-apps/toybox/toybox-0.8.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing savedconfig toolchain-funcs
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/landley/toybox.git"
+else
+ SRC_URI="https://landley.net/code/toybox/downloads/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Common linux commands in a multicall binary"
+HOMEPAGE="https://landley.net/code/toybox/"
+
+# The source code does not explicitly say that it's BSD, but the author has repeatedly said it
+LICENSE="BSD-2"
+SLOT="0"
+
+# makefile is stupid
+#RESTRICT="test"
+
+src_prepare() {
+ default
+ restore_config .config
+}
+
+src_configure() {
+ tc-export CC STRIP
+ export HOSTCC="$(tc-getBUILD_CC)"
+ export OPTIMIZE="${CFLAGS}"
+
+ if [[ -f .config ]]; then
+ yes "" | emake -j1 oldconfig > /dev/null
+ return 0
+ else
+ einfo "Could not locate user configfile, so we will save a default one"
+ emake -j1 defconfig > /dev/null
+ fi
+}
+
+src_compile() {
+ unset CROSS_COMPILE
+ export CPUS=$(makeopts_jobs)
+ emake V=1
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ save_config .config
+ newbin generated/unstripped/toybox toybox
+}