summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2024-12-22 14:20:44 -0500
committerMike Gilbert <floppym@gentoo.org>2024-12-22 14:20:44 -0500
commit79294bea8dac90ef83065fe9632148c90d8bfeb5 (patch)
treed6769e01f9da6b0fb0e8ceec6dab6f6193a017ca /sys-apps
parentsci-libs/pdal: add deps for test (diff)
downloadgentoo-79294bea8dac90ef83065fe9632148c90d8bfeb5.tar.gz
gentoo-79294bea8dac90ef83065fe9632148c90d8bfeb5.tar.bz2
gentoo-79294bea8dac90ef83065fe9632148c90d8bfeb5.zip
sys-apps/sandbox: add 2.42
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sandbox/Manifest1
-rw-r--r--sys-apps/sandbox/sandbox-2.42.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sys-apps/sandbox/Manifest b/sys-apps/sandbox/Manifest
index e9a574e988a0..98e4743d346d 100644
--- a/sys-apps/sandbox/Manifest
+++ b/sys-apps/sandbox/Manifest
@@ -1,3 +1,4 @@
DIST sandbox-2.39.tar.xz 462796 BLAKE2B 330c6f896eba6ff2a38eb8a5d1ff9b242d0e42ab03734254b1851f36cc851c32e7ed3d32afe07374b6e264cb0a922d25b010af5269f60fc5142b9036008f0945 SHA512 5eed5d828eb904b15d52736ea8835128e805f0274f2152d033ae6d93f1df3bc1f50ed23d7544c37ee06b14cb2c301110730e1de3097d6f7032069ef8dbbbd28c
DIST sandbox-2.40.tar.xz 465824 BLAKE2B 1e7e8b1c69807d493d5ca242d746b07aa669e18f9aab60cbfd7fe66500ac6822f8b9236077c370ec7e580c8c056f2ccc7825017cd015fca4497e967dcb93cc82 SHA512 e734f380943cc573847f48789a6ad724a3a3fe1017cb7e4bffcd75d2f758d85e937511bbc2eccd0224301b56bc0dd38c92fbaf2d268132be4985f5a768593bdc
DIST sandbox-2.41.tar.xz 468180 BLAKE2B cb00ec8605b9b51ce559a9e9baa68d757e17900abbe9fff890ddbabcc001e47d72a0e7a693104a6594d3d86bc9afebc6945ed3ec101fd67bfe8a855de3ef010f SHA512 ac787ecc61a625717a66fef663f34ddc855c144226f80e1593033f06ccd9dbd526ffbd032a7b142404a0a5a5aea4b813c9258e9c2202c2e9b0574aa35aae3ef8
+DIST sandbox-2.42.tar.xz 468676 BLAKE2B c4a17c9c6c1644bf27565eab8d76b37689f2a1ca2083d30d65deffd76449f69f68dd4d56ebb19236ca3111996c037fa4e1e5d034dc942349b93ba7c4c68f6248 SHA512 05076394cec77a6443ccc9ba31209fac32c57497210b817e71d10ffc75388673de75de8be6a86ee2f798a285e02ed1af8f134a988eceb6824a3e94bd5be4fc62
diff --git a/sys-apps/sandbox/sandbox-2.42.ebuild b/sys-apps/sandbox/sandbox-2.42.ebuild
new file mode 100644
index 000000000000..7279694e8993
--- /dev/null
+++ b/sys-apps/sandbox/sandbox-2.42.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit flag-o-matic multilib-minimal multiprocessing
+
+DESCRIPTION="sandbox'd LD_PRELOAD hack"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Sandbox"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="+nnp"
+
+# pax-utils lower bound for bug #265376
+DEPEND=">=app-misc/pax-utils-0.1.19"
+# Avoid folks installing with older file, bug #889046. We still need the
+# >= dep in Portage but this is a safety net if people do partial upgrades.
+RDEPEND="!<sys-apps/file-5.44-r1"
+BDEPEND="app-arch/xz-utils"
+
+has sandbox_death_notice ${EBUILD_DEATH_HOOKS} || EBUILD_DEATH_HOOKS+=" sandbox_death_notice"
+
+sandbox_death_notice() {
+ ewarn "If configure failed with a 'cannot run C compiled programs' error, try this:"
+ ewarn "FEATURES='-sandbox -usersandbox' emerge sandbox"
+}
+
+src_prepare() {
+ default
+
+ if ! use nnp ; then
+ sed -i 's:PR_SET_NO_NEW_PRIVS:___disable_nnp_hack:' src/sandbox.c || die
+ fi
+
+ # sandbox uses `__asm__ (".symver "...` which does
+ # not play well with gcc's LTO: https://gcc.gnu.org/PR48200
+ filter-lto
+}
+
+multilib_src_configure() {
+ filter-lfs-flags #90228
+
+ ECONF_SOURCE="${S}" econf
+}
+
+multilib_src_test() {
+ # Default sandbox build will run with --jobs set to # cpus.
+ emake check TESTSUITEFLAGS="--jobs=$(makeopts_jobs)"
+}
+
+multilib_src_install_all() {
+ doenvd "${FILESDIR}"/09sandbox
+
+ dodoc AUTHORS ChangeLog* README.md
+}
+
+pkg_postinst() {
+ mkdir -p "${EROOT}"/var/log/sandbox
+ chown root:portage "${EROOT}"/var/log/sandbox
+ chmod 0770 "${EROOT}"/var/log/sandbox
+}