summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2016-06-24 23:07:30 -0400
committerMike Frysinger <vapier@gentoo.org>2016-06-24 23:09:12 -0400
commitb60e6814ea6c95cedac4e03c2a1ce574207dea30 (patch)
tree38f36771de06e57d23add4776c1a80484262b7fd /sys-apps
parentgames-emulation/dolphin: Updates locales and QT flag, bug #561914 (diff)
downloadgentoo-b60e6814ea6c95cedac4e03c2a1ce574207dea30.tar.gz
gentoo-b60e6814ea6c95cedac4e03c2a1ce574207dea30.tar.bz2
gentoo-b60e6814ea6c95cedac4e03c2a1ce574207dea30.zip
sys-apps/file: build magic.h before libmagic.la #586444
Since the header is a BUILT_SOURCES which is normally created only when you run `make all`, make sure we generate it by hand before building the library in the multilib case.
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/file/file-5.28.ebuild4
-rw-r--r--sys-apps/file/file-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-apps/file/file-5.28.ebuild b/sys-apps/file/file-5.28.ebuild
index 6ebccd647f22..ee20eaae3ae8 100644
--- a/sys-apps/file/file-5.28.ebuild
+++ b/sys-apps/file/file-5.28.ebuild
@@ -78,7 +78,9 @@ multilib_src_compile() {
if multilib_is_native_abi ; then
emake
else
- emake -C src libmagic.la
+ cd src
+ emake magic.h #586444
+ emake libmagic.la
fi
}
diff --git a/sys-apps/file/file-9999.ebuild b/sys-apps/file/file-9999.ebuild
index 658a92fa32a2..1bdaeccf4330 100644
--- a/sys-apps/file/file-9999.ebuild
+++ b/sys-apps/file/file-9999.ebuild
@@ -78,7 +78,9 @@ multilib_src_compile() {
if multilib_is_native_abi ; then
emake
else
- emake -C src libmagic.la
+ cd src
+ emake magic.h #586444
+ emake libmagic.la
fi
}