summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatoro Mahri <matoro_gentoo@matoro.tk>2024-06-13 20:14:35 -0400
committerMaciej Barć <xgqt@gentoo.org>2024-06-14 09:27:19 +0200
commitd8cfb771b47bd0a18c0772d6c950726e473e458f (patch)
tree104a4a4af6cd0abbceddef443bd276a91092bf20 /sys-apps
parentmedia-libs/vigra: further py3.12 fixes (diff)
downloadgentoo-d8cfb771b47bd0a18c0772d6c950726e473e458f.tar.gz
gentoo-d8cfb771b47bd0a18c0772d6c950726e473e458f.tar.bz2
gentoo-d8cfb771b47bd0a18c0772d6c950726e473e458f.zip
sys-apps/polychromatic: wire up tests
Bug: https://bugs.gentoo.org/933050 Signed-off-by: Matoro Mahri <matoro_gentoo@matoro.tk> Closes: https://github.com/gentoo/gentoo/pull/37151 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/polychromatic/polychromatic-0.9.1.ebuild6
-rw-r--r--sys-apps/polychromatic/polychromatic-9999.ebuild6
2 files changed, 12 insertions, 0 deletions
diff --git a/sys-apps/polychromatic/polychromatic-0.9.1.ebuild b/sys-apps/polychromatic/polychromatic-0.9.1.ebuild
index 19e9c50db521..17566f06c680 100644
--- a/sys-apps/polychromatic/polychromatic-0.9.1.ebuild
+++ b/sys-apps/polychromatic/polychromatic-0.9.1.ebuild
@@ -51,6 +51,12 @@ DOC_CONTENTS="To automatically start up Polychromatic on session login copy
/usr/share/polychromatic/polychromatic-autostart.desktop file into Your user's
~/.config/autostart/ directory."
+src_test() {
+ rm -rf "locale" || die
+ ln -svf "${BUILD_DIR}/locale" "locale" || die
+ PYTHONPATH="tests:${PYTHONPATH}" "${EPYTHON}" "tests/runner.py" || die
+}
+
src_install() {
meson_src_install
python_optimize
diff --git a/sys-apps/polychromatic/polychromatic-9999.ebuild b/sys-apps/polychromatic/polychromatic-9999.ebuild
index 19e9c50db521..17566f06c680 100644
--- a/sys-apps/polychromatic/polychromatic-9999.ebuild
+++ b/sys-apps/polychromatic/polychromatic-9999.ebuild
@@ -51,6 +51,12 @@ DOC_CONTENTS="To automatically start up Polychromatic on session login copy
/usr/share/polychromatic/polychromatic-autostart.desktop file into Your user's
~/.config/autostart/ directory."
+src_test() {
+ rm -rf "locale" || die
+ ln -svf "${BUILD_DIR}/locale" "locale" || die
+ PYTHONPATH="tests:${PYTHONPATH}" "${EPYTHON}" "tests/runner.py" || die
+}
+
src_install() {
meson_src_install
python_optimize