summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2017-05-10 14:45:28 +0800
committerJason Zaman <perfinion@gentoo.org>2017-05-10 15:18:53 +0800
commitf0b40d3e6fa04a2c34785f04bf48db705a5df3b9 (patch)
tree9171b64e14dcb7a57d4424ae64f29c8cd65db7cd /sys-auth/consolekit/files
parentdev-ruby/best_in_place: add ruby22, drop integration tests (diff)
downloadgentoo-f0b40d3e6fa04a2c34785f04bf48db705a5df3b9.tar.gz
gentoo-f0b40d3e6fa04a2c34785f04bf48db705a5df3b9.tar.bz2
gentoo-f0b40d3e6fa04a2c34785f04bf48db705a5df3b9.zip
sys-auth/consolekit: bump to 1.1.1
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'sys-auth/consolekit/files')
-rw-r--r--sys-auth/consolekit/files/consolekit-1.0.0.initd6
-rw-r--r--sys-auth/consolekit/files/consolekit-1.1.1-0001-Fix-enable-libudev-configure-flag.patch41
2 files changed, 44 insertions, 3 deletions
diff --git a/sys-auth/consolekit/files/consolekit-1.0.0.initd b/sys-auth/consolekit/files/consolekit-1.0.0.initd
index 05a818a65d95..4fd1140fe209 100644
--- a/sys-auth/consolekit/files/consolekit-1.0.0.initd
+++ b/sys-auth/consolekit/files/consolekit-1.0.0.initd
@@ -1,9 +1,9 @@
#!/sbin/openrc-run
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
description="consolekit - tracks login sessions and seats"
-pidfile="/var/run/ConsoleKit/pid"
+pidfile="/run/ConsoleKit/pid"
command="/usr/sbin/console-kit-daemon"
depend() {
@@ -12,5 +12,5 @@ depend() {
}
start_pre() {
- checkpath -q -d -m 0755 /var/run/ConsoleKit
+ checkpath -q -d -m 0755 /run/ConsoleKit
}
diff --git a/sys-auth/consolekit/files/consolekit-1.1.1-0001-Fix-enable-libudev-configure-flag.patch b/sys-auth/consolekit/files/consolekit-1.1.1-0001-Fix-enable-libudev-configure-flag.patch
new file mode 100644
index 000000000000..c6cc61d47843
--- /dev/null
+++ b/sys-auth/consolekit/files/consolekit-1.1.1-0001-Fix-enable-libudev-configure-flag.patch
@@ -0,0 +1,41 @@
+From 91f517bb6e19315c3a9971b2449f2b2e049e785b Mon Sep 17 00:00:00 2001
+From: Eric Koegel <eric.koegel@gmail.com>
+Date: Wed, 10 May 2017 07:13:23 +0300
+Subject: [PATCH] Fix --enable-libudev configure flag
+
+Thanks for perfinion to pointing this out.
+---
+ configure.ac | 10 +++++-----
+ 1 file changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 2d927fe..b17801a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -364,10 +364,10 @@ AM_CONDITIONAL([ENABLE_UDEV_ACL], [test "x$enable_udev_acl" = "xyes"])
+ # libudev - use udev as a device manager for ck-device-udev.c
+ have_libudev=no
+ AC_ARG_ENABLE([libudev],
+- AS_HELP_STRING([--enable-udev], [Enable udev support @<:@default=auto@:>@]),
+- [enable_udev=$enableval],
+- [enable_udev=auto])
+-AS_IF([test "x$enable_udev" != "xno"], [
++ AS_HELP_STRING([--enable-libudev], [Enable udev support @<:@default=auto@:>@]),
++ [enable_libudev=$enableval],
++ [enable_libudev=auto])
++AS_IF([test "x$enable_libudev" != "xno"], [
+ PKG_CHECK_MODULES([LIBUDEV], [libudev], [have_libudev=yes], [have_libudev=no])
+ PKG_CHECK_MODULES([LIBDRM], [libdrm], [have_libdrm=yes], [have_libdrm=no])
+ AC_CHECK_LIB([prop], [prop_dictionary_get_cstring], [have_libprop=yes], [have_libprop=no])
+@@ -384,7 +384,7 @@ AS_IF([test "x$enable_udev" != "xno"], [
+ LIBUDEV_LIBS="$LIBUDEV_LIBS -lprop"
+ fi
+
+- if test "x$enable_udev" = "xyes" -a "x$have_udev" = "xno"; then
++ if test "x$enable_libudev" = "xyes" -a "x$have_libudev" = "xno"; then
+ AC_MSG_ERROR([udev support explicitly requested but dependencies not found])
+ fi
+ ])
+--
+2.10.2
+