summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-24 19:35:38 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-24 19:36:08 +0100
commit383ac8b9e905ae1696b4ccd7b75c26d45613e055 (patch)
tree2fe3c156cf4f3e8d28cf08c2f5a78a31deada502 /sys-auth/libnss-cache
parentmedia-tv/dvbtune: respect user's CC (diff)
downloadgentoo-383ac8b9e905ae1696b4ccd7b75c26d45613e055.tar.gz
gentoo-383ac8b9e905ae1696b4ccd7b75c26d45613e055.tar.bz2
gentoo-383ac8b9e905ae1696b4ccd7b75c26d45613e055.zip
sys-auth/libnss-cache: disable tests
Reported-by: Diego Elio Pettenò Closes: https://bugs.gentoo.org/422567 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'sys-auth/libnss-cache')
-rw-r--r--sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
index 0ad34429a489..3fe430b86550 100644
--- a/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
+++ b/sys-auth/libnss-cache/libnss-cache-0.10.2.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit multilib-minimal toolchain-funcs
@@ -12,7 +12,8 @@ SRC_URI="https://nsscache.googlecode.com/files/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+
+RESTRICT=test # needs special sudo configuration, bug #422567
PATCHES=(
"${FILESDIR}"/${PN}-0.10.1-make.patch
@@ -29,5 +30,5 @@ multilib_src_compile() {
}
multilib_src_install() {
- emake DESTDIR="${ED}" LIBDIR="${ED%/}/usr/$(get_libdir)" install
+ emake DESTDIR="${ED}" LIBDIR="${ED}/usr/$(get_libdir)" install
}