summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-12-17 10:35:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-12-18 00:00:33 +0100
commit03793f067e691d128f2c4d2d611445438ecf1a4d (patch)
treed84f438b64c9c72070355ff167bea1e4e58b68e5 /sys-auth
parentlxqt-base/lxqt-policykit: Prepare for sys-auth/polkit-qt to gain IUSE qt5,qt6 (diff)
downloadgentoo-03793f067e691d128f2c4d2d611445438ecf1a4d.tar.gz
gentoo-03793f067e691d128f2c4d2d611445438ecf1a4d.tar.bz2
gentoo-03793f067e691d128f2c4d2d611445438ecf1a4d.zip
sys-auth/polkit-qt: add 0.175.0
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/polkit-qt/Manifest1
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.175.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/Manifest b/sys-auth/polkit-qt/Manifest
index dc394746a2ad..4818f581c226 100644
--- a/sys-auth/polkit-qt/Manifest
+++ b/sys-auth/polkit-qt/Manifest
@@ -1 +1,2 @@
DIST polkit-qt-1-0.114.0.tar.xz 58384 BLAKE2B e788198e386797ba9b4c228a451dde703f83e79c81eacaf805e431a3f60c0832adc3faef4616e3008dfaa816d7dc5a7a80aaf02936ea232373e78e0d008724ca SHA512 4a16d9428d5ccc0107dcbd67c29ecba196424e555dc43d55cf2b6e0e7b72c99f894e9c994eaed85a9536010d67a19f20fe74f792c0d6b9ca0e05ce85f655f9a8
+DIST polkit-qt-1-0.175.0.tar.xz 58208 BLAKE2B 521c0db2b4451443cf2464a668447fd81c0afe4a6cd1d24ef54037a052c024d1bb752925b5390444ffe7828427998c7cbb88e81f22ed9703d9d73a2031cb2f43 SHA512 cf3abe1f0ce38c7ab04f637cbab3896fd006112a81948cf3832a43962bdb4426add9bcfb157efb0c7490d037622f11f93e4fb936973d35c6df2da149c1b12ffc
diff --git a/sys-auth/polkit-qt/polkit-qt-0.175.0.ebuild b/sys-auth/polkit-qt/polkit-qt-0.175.0.ebuild
new file mode 100644
index 000000000000..1a7af34abfac
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.175.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="libraries"
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake kde.org multibuild
+
+DESCRIPTION="Qt wrapper around polkit-1 client libraries"
+HOMEPAGE="https://api.kde.org/polkit-qt-1/html/"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ SRC_URI="mirror://kde/unstable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="+qt5 qt6"
+REQUIRED_USE="|| ( qt5 qt6 )"
+
+RDEPEND="
+ dev-libs/glib:2
+ >=sys-auth/polkit-0.103
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ )
+ qt6? ( dev-qt/qtbase:6[dbus,gui,widgets] )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+}
+
+src_configure() {
+ myconfigure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=OFF
+ -DQT_MAJOR_VERSION=${MULTIBUILD_VARIANT/qt/}
+ )
+ cmake_src_configure
+ }
+ multibuild_foreach_variant myconfigure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+}