summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-21 12:10:16 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-21 12:16:12 +0200
commitf81f95471c25e346bac4c489a058af14f4e9b68e (patch)
treeea1a35b41ee8144164d9a741aa5b0f862f6e5393 /sys-block
parentnet-nds/gss-proxy: Bump to version 0.8.2 (diff)
downloadgentoo-f81f95471c25e346bac4c489a058af14f4e9b68e.tar.gz
gentoo-f81f95471c25e346bac4c489a058af14f4e9b68e.tar.bz2
gentoo-f81f95471c25e346bac4c489a058af14f4e9b68e.zip
sys-block/thin-provisioning-tools: Improved live ebuild.
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild31
1 files changed, 20 insertions, 11 deletions
diff --git a/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild b/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild
index 96d1cf0b494d..8b0eb97b2165 100644
--- a/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild
+++ b/sys-block/thin-provisioning-tools/thin-provisioning-tools-9999.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-EGIT_REPO_URI='https://github.com/jthornber/thin-provisioning-tools.git'
-inherit autotools flag-o-matic $SCM
+inherit autotools flag-o-matic
DESCRIPTION="A suite of tools for thin provisioning on Linux"
HOMEPAGE="https://github.com/jthornber/thin-provisioning-tools"
@@ -13,6 +11,9 @@ HOMEPAGE="https://github.com/jthornber/thin-provisioning-tools"
if [[ ${PV} != *9999 ]]; then
SRC_URI="https://github.com/jthornber/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+else
+ inherit git-r3
+ EGIT_REPO_URI='https://github.com/jthornber/thin-provisioning-tools.git'
fi
LICENSE="GPL-3"
@@ -25,14 +26,20 @@ RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )
test? (
- || ( dev-lang/ruby:2.5 dev-lang/ruby:2.4 dev-lang/ruby:2.3 )
+ || (
+ dev-lang/ruby:2.6
+ dev-lang/ruby:2.5
+ dev-lang/ruby:2.4
+ )
>=dev-cpp/gtest-1.8.0
dev-util/cucumber
dev-util/aruba
)
dev-libs/boost"
-PATCHES=( "${FILESDIR}"/${PN}-0.7.0-build-fixes.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.0-build-fixes.patch
+)
src_prepare() {
default
@@ -41,11 +48,13 @@ src_prepare() {
src_configure() {
use static && append-ldflags -static
- STRIP=true econf \
- --prefix="${EPREFIX}"/ \
- --bindir="${EPREFIX}"/sbin \
- --with-optimisation='' \
+ local myeconfargs=(
+ --prefix="${EPREFIX}"/
+ --bindir="${EPREFIX}"/sbin
+ --with-optimisation=''
$(use_enable test testing)
+ )
+ STRIP=true econf "${myeconfargs[@]}"
}
src_compile() {
@@ -58,6 +67,6 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" DATADIR="${ED%/}/usr/share" install
+ emake DESTDIR="${D}" DATADIR="${D%/}/usr/share" install
dodoc README.md TODO.org
}