summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-06-02 19:49:14 -0400
committerAaron Bauman <bman@gentoo.org>2018-06-02 22:58:22 -0400
commitce14c2ee09d35a904eb8264cb328f4ae1d47f65b (patch)
tree054f2fc27e8089cb41dc84582faf7730076e93a8 /sys-boot/grub-static/grub-static-0.97.ebuild
parentsys-cluster/cman-lib: drop old EAPI (diff)
downloadgentoo-ce14c2ee09d35a904eb8264cb328f4ae1d47f65b.tar.gz
gentoo-ce14c2ee09d35a904eb8264cb328f4ae1d47f65b.tar.bz2
gentoo-ce14c2ee09d35a904eb8264cb328f4ae1d47f65b.zip
sys-boot/grub-static: drop old EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'sys-boot/grub-static/grub-static-0.97.ebuild')
-rw-r--r--sys-boot/grub-static/grub-static-0.97.ebuild77
1 files changed, 0 insertions, 77 deletions
diff --git a/sys-boot/grub-static/grub-static-0.97.ebuild b/sys-boot/grub-static/grub-static-0.97.ebuild
deleted file mode 100644
index f25a8ea41bf3..000000000000
--- a/sys-boot/grub-static/grub-static-0.97.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit mount-boot
-
-DESCRIPTION="Static GNU GRUB boot loader"
-
-HOMEPAGE="https://www.gnu.org/software/grub/"
-SRC_URI="mirror://gentoo/grub-static-${PV}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-* amd64 ~x86"
-IUSE=""
-DEPEND="!<sys-boot/grub-2"
-RDEPEND="${DEPEND}"
-
-src_install() {
- cp -a "${WORKDIR}"/* "${D}"/
-}
-
-#
-# Everything below is directly copied from the grub ebuild
-# please try to keep it in sync
-#
-
-setup_boot_dir() {
- local dir="${1}"
-
- [[ ! -e "${dir}" ]] && die "${dir} does not exist!"
- [[ ! -e "${dir}"/grub ]] && mkdir "${dir}/grub"
-
- # change menu.lst to grub.conf
- if [[ ! -e "${dir}"/grub/grub.conf ]] && [[ -e "${dir}"/grub/menu.lst ]] ; then
- mv -f "${dir}"/grub/menu.lst "${dir}"/grub/grub.conf
- ewarn
- ewarn "*** IMPORTANT NOTE: menu.lst has been renamed to grub.conf"
- ewarn
- fi
-
- if [[ ! -e "${dir}"/grub/menu.lst ]]; then
- einfo "Linking from new grub.conf name to menu.lst"
- ln -snf grub.conf "${dir}"/grub/menu.lst
- fi
-
- [[ -e "${dir}"/grub/stage2 ]] && mv "${dir}"/grub/stage2{,.old}
-
- einfo "Copying files from /lib/grub and /usr/lib/grub to ${dir}"
- for x in /lib*/grub/*/* /usr/lib*/grub/*/* ; do
- [[ -f "${x}" ]] && cp -p "${x}" "${dir}"/grub/
- done
-
- if [[ -e "${dir}"/grub/grub.conf ]] ; then
- egrep \
- -v '^[[:space:]]*(#|$|default|fallback|initrd|password|splashimage|timeout|title)' \
- "${dir}"/grub/grub.conf | \
- /sbin/grub --batch \
- --device-map="${dir}"/grub/device.map \
- > /dev/null
- fi
-}
-
-pkg_postinst() {
- [[ "${ROOT}" != "/" ]] && return 0
- [[ -n ${DONT_MOUNT_BOOT} ]] && return 0
- setup_boot_dir /boot
- einfo "To install grub files to another device (like a usb stick), just run:"
- einfo " emerge --config =${PF}"
-}
-
-pkg_config() {
- local dir
- einfo "Enter the directory where you want to setup grub:"
- read dir
- setup_boot_dir "${dir}"
-}