summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBiosias <jakub@gdos.sk>2024-07-17 00:09:27 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2024-07-17 10:06:54 +0200
commit0de20dfc66d86f5679adc2309abc43347b970926 (patch)
tree3a4c3e0557ba8040811bb82b0f726177efcaa1cb /sys-boot
parentsys-boot/uefi-mkconfig: drop 1.4, 1.5 (diff)
downloadgentoo-0de20dfc66d86f5679adc2309abc43347b970926.tar.gz
gentoo-0de20dfc66d86f5679adc2309abc43347b970926.tar.bz2
gentoo-0de20dfc66d86f5679adc2309abc43347b970926.zip
sys-boot/uefi-mkconfig: add 2.1
Signed-off-by: Biosias <jakub@gdos.sk> Closes: https://github.com/gentoo/gentoo/pull/37584 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/uefi-mkconfig/Manifest1
-rw-r--r--sys-boot/uefi-mkconfig/uefi-mkconfig-2.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-boot/uefi-mkconfig/Manifest b/sys-boot/uefi-mkconfig/Manifest
index 4b3d33dfb49f..122231a0410e 100644
--- a/sys-boot/uefi-mkconfig/Manifest
+++ b/sys-boot/uefi-mkconfig/Manifest
@@ -1 +1,2 @@
DIST uefi-mkconfig-1.6.tar.gz 8620 BLAKE2B 57a48be15a976cc628f04e263fcbc1c56296f9d2b8ff11e70ab9239723f168e08775042fa86ab49e85d212aa719e6465acf883debe46f4a7f3d57edf3d07dd09 SHA512 df4595f5c05b812e7199fc19564bd899b345952f23014f9f0851e7da4b812b93583d52b9955edde3f7d05c182f29b120b7201d69493931813b2caf8ffd2e6f14
+DIST uefi-mkconfig-2.1.tar.gz 10083 BLAKE2B c78a2f38b66c643c23442c5159d70272099babea9dc5bc7eb68628ff09cf307375a32e7886ed8e597dc05233aa49d6aa13ec86466b0aaebd33663667848867fe SHA512 466f4d902e84ec19d17f4b43bacced6372c5c0a469c245e267a5166b0a2d2a3ee2c1409d83129cc5088305367e0a53249990f45119b8c5522235fd65a19dc5fb
diff --git a/sys-boot/uefi-mkconfig/uefi-mkconfig-2.1.ebuild b/sys-boot/uefi-mkconfig/uefi-mkconfig-2.1.ebuild
new file mode 100644
index 000000000000..8b272798d1ff
--- /dev/null
+++ b/sys-boot/uefi-mkconfig/uefi-mkconfig-2.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info optfeature
+
+DESCRIPTION="Automatic management of UEFI entries"
+HOMEPAGE="https://github.com/Biosias/uefi-mkconfig"
+SRC_URI="https://github.com/Biosias/uefi-mkconfig/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ app-shells/bash
+ sys-boot/efibootmgr
+"
+
+CONFIG_CHECK="EFI_STUB"
+
+src_install() {
+ dobin uefi-mkconfig
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "uefi-mkconfig: Automatic management of UEFI entries"
+ elog "Run uefi-mkconfig while having all efi partitions mounted"
+ elog "Please use with care, this package was tested on a limited number of machines"
+ elog "Some problems may arise due to different implementations of UEFI"
+ elog "Don't forget to add kernel commands to the configuration file before using this package!"
+ elog
+ optfeature "Add UEFI entries on kernel installation " \ "sys-kernel/installkernel[-systemd,efistub]"
+}