summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2020-11-08 15:50:35 -0500
committerJoshua Kinard <kumba@gentoo.org>2020-11-08 15:51:03 -0500
commit6f94f3741de3665ae7b1d32d52438c52cd366cf0 (patch)
tree085ccfb0c6a8863b7a88304577bd608aea4b2208 /sys-boot
parentkde-plasma/plasma-systemmonitor: add ~ppc64 keyword (diff)
downloadgentoo-6f94f3741de3665ae7b1d32d52438c52cd366cf0.tar.gz
gentoo-6f94f3741de3665ae7b1d32d52438c52cd366cf0.tar.bz2
gentoo-6f94f3741de3665ae7b1d32d52438c52cd366cf0.zip
sys-boot/lilo: EAPI update and gcc-10 fix
Update lilo-24.1's ebuild to EAPI7 and add a patch from Debian to fix compilation issues with gcc-10.x and up to both lilo-24.1 and lilo-24.2. Closes: https://bugs.gentoo.org/723262 Signed-off-by: Joshua Kinard <kumba@gentoo.org> Package-Manager: Portage-3.0.9, Repoman-3.0.2
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/lilo/files/lilo-24.x-fix-gcc-10.patch51
-rw-r--r--sys-boot/lilo/lilo-24.1.ebuild10
-rw-r--r--sys-boot/lilo/lilo-24.2.ebuild1
3 files changed, 59 insertions, 3 deletions
diff --git a/sys-boot/lilo/files/lilo-24.x-fix-gcc-10.patch b/sys-boot/lilo/files/lilo-24.x-fix-gcc-10.patch
new file mode 100644
index 000000000000..c46b9eebdea0
--- /dev/null
+++ b/sys-boot/lilo/files/lilo-24.x-fix-gcc-10.patch
@@ -0,0 +1,51 @@
+Description: Fix ftbfs with GCC-10
+
+Author: Ryan Finnie <ryan@finnie.org>
+Bug-Debian: https://bugs.debian.org/957490
+Forwarded: no
+
+---
+
+--- a/src/raid.h
++++ b/src/raid.h
+@@ -8,7 +8,7 @@
+ * in the source directory.
+ */
+
+-int do_md_install, ndisk, md_bios;
++extern int ndisk, md_bios;
+
+ int raid_setup(void);
+ void raid_final(void);
+--- a/src/bsect.c
++++ b/src/bsect.c
+@@ -54,8 +54,6 @@
+ #endif
+
+
+-int boot_dev_nr;
+-
+ static BOOT_SECTOR bsect,bsect_orig;
+ static MENUTABLE menuparams;
+ static DESCR_SECTORS descrs;
+--- a/src/identify.c
++++ b/src/identify.c
+@@ -19,7 +19,6 @@
+ #include "common.h"
+ #include "cfg.h"
+
+-char *identify;
+ static char *opt;
+ static char *first, *dflt;
+ static int idefault;
+--- a/src/raid.c
++++ b/src/raid.c
+@@ -41,7 +41,7 @@
+ static int raid_bios[MAX_RAID+1];
+ static int device;
+ enum {MD_NULL=0, MD_PARALLEL, MD_MIXED, MD_SKEWED};
+-int do_md_install, ndisk, md_bios;
++int ndisk, md_bios;
+ static char *raid_list[MAX_RAID];
+ static int list_index[MAX_RAID];
+ static int nlist, faulty;
diff --git a/sys-boot/lilo/lilo-24.1.ebuild b/sys-boot/lilo/lilo-24.1.ebuild
index aa4787b06c10..4627ce7347c4 100644
--- a/sys-boot/lilo/lilo-24.1.ebuild
+++ b/sys-boot/lilo/lilo-24.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="7"
inherit eutils flag-o-matic toolchain-funcs
@@ -25,10 +25,14 @@ DEPEND=">=sys-devel/bin86-0.15.5"
RDEPEND="device-mapper? ( >=sys-fs/lvm2-2.02.45 )"
src_prepare() {
+ default
+
# this patch is needed when booting PXE and the device you're using
# emulates vga console via serial console.
# IE.. B.B.o.o.o.o.t.t.i.i.n.n.g.g....l.l.i.i.n.n.u.u.x.x and stair stepping.
- use pxeserial && epatch "${FILESDIR}/${P}-novga.patch"
+ use pxeserial && eapply "${FILESDIR}/${P}-novga.patch"
+
+ eapply "${FILESDIR}/${PN}-24.x-fix-gcc-10.patch"
# Do not strip and have parallel make
# FIXME: images/Makefile does weird stuff
diff --git a/sys-boot/lilo/lilo-24.2.ebuild b/sys-boot/lilo/lilo-24.2.ebuild
index 73f9ea6efbb4..66ac79f03145 100644
--- a/sys-boot/lilo/lilo-24.2.ebuild
+++ b/sys-boot/lilo/lilo-24.2.ebuild
@@ -33,6 +33,7 @@ src_prepare() {
use pxeserial && eapply "${FILESDIR}/${PN}-24.1-novga.patch"
eapply "${FILESDIR}/${PN}-24.2-add-nvme-support.patch"
+ eapply "${FILESDIR}/${PN}-24.x-fix-gcc-10.patch"
# Do not strip and have parallel make
# FIXME: images/Makefile does weird stuff