summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-04 11:46:56 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-04 11:48:20 -0500
commite04e2290fb19632e3ba0d1a1f8cb5763f3f364ec (patch)
treed8e9a9eb01dd872306965c5aec9926e69eb977b2 /sys-cluster/hubble
parentsys-cluster/cilium-cli: new package, add 0.12.1 (diff)
downloadgentoo-e04e2290fb19632e3ba0d1a1f8cb5763f3f364ec.tar.gz
gentoo-e04e2290fb19632e3ba0d1a1f8cb5763f3f364ec.tar.bz2
gentoo-e04e2290fb19632e3ba0d1a1f8cb5763f3f364ec.zip
sys-cluster/hubble: new package, add 0.10.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster/hubble')
-rw-r--r--sys-cluster/hubble/Manifest1
-rw-r--r--sys-cluster/hubble/hubble-0.10.0.ebuild27
-rw-r--r--sys-cluster/hubble/metadata.xml8
3 files changed, 36 insertions, 0 deletions
diff --git a/sys-cluster/hubble/Manifest b/sys-cluster/hubble/Manifest
new file mode 100644
index 000000000000..5343f802fbd6
--- /dev/null
+++ b/sys-cluster/hubble/Manifest
@@ -0,0 +1 @@
+DIST hubble-0.10.0.tar.gz 6453598 BLAKE2B e3b91e4aa3fd7de6cc474a7f99e37cbde542ae66d3dc2e509cc9db36e3d0e127803fb84b972c017cafa598663f5d845832c246b4fc99420dade4f61e94ad4e2f SHA512 d8f6347954a7fc4ff2a707c7a21e699c562647c9d4eea238345db9c93fdf232cf52482c8f79046bdee1fff8d34839eaf4b80de6877b18d45cec77a8190ef7f58
diff --git a/sys-cluster/hubble/hubble-0.10.0.ebuild b/sys-cluster/hubble/hubble-0.10.0.ebuild
new file mode 100644
index 000000000000..c9c9ba326b12
--- /dev/null
+++ b/sys-cluster/hubble/hubble-0.10.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+# make sure this gets updated on every bump
+GIT_HASH=daec1c89
+
+DESCRIPTION="Network, Service & Security Observability for Kubernetes using eBPF"
+HOMEPAGE="https://cilium.io"
+SRC_URI="https://github.com/cilium/hubble/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake GIT_HASH=${GIT_HASH}
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ dobin hubble
+}
diff --git a/sys-cluster/hubble/metadata.xml b/sys-cluster/hubble/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/sys-cluster/hubble/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>