summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-02-20 12:51:24 -0600
committerWilliam Hubbs <williamh@gentoo.org>2022-02-20 12:52:48 -0600
commit010bb3a5ba073cc25e34ec9c001154e38aa7f789 (patch)
tree83e8e5b74c30c25e7900c46ba0fdbd1aa3077b26 /sys-cluster
parentapp-misc/tracker: Fix test dependencies (diff)
downloadgentoo-010bb3a5ba073cc25e34ec9c001154e38aa7f789.tar.gz
gentoo-010bb3a5ba073cc25e34ec9c001154e38aa7f789.tar.bz2
gentoo-010bb3a5ba073cc25e34ec9c001154e38aa7f789.zip
sys-cluster/nomad: remove vulnerable versions
Bug: https://bugs.gentoo.org/812494 Bug: https://bugs.gentoo.org/833157 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nomad/Manifest1
-rw-r--r--sys-cluster/nomad/metadata.xml1
-rw-r--r--sys-cluster/nomad/nomad-1.0.9.ebuild45
3 files changed, 0 insertions, 47 deletions
diff --git a/sys-cluster/nomad/Manifest b/sys-cluster/nomad/Manifest
index b38f14d5d906..1d5e117082e7 100644
--- a/sys-cluster/nomad/Manifest
+++ b/sys-cluster/nomad/Manifest
@@ -1,3 +1,2 @@
-DIST nomad-1.0.9.tar.gz 40563203 BLAKE2B 5db3bce093ae873907572e5f67640fac162e4c4ffe436f2acd3ac9fe8da509f451ff73c948dcd49d10eb101afdfe5285b2906986983b938034c64aab8d0cab4d SHA512 66a00f15a16b57e8a3f97c43301bd9aaab76e185b56fe45193eb0e7c25e83fbcf1a7072f2d5fe4c533a00e63c71f3ec941a05cf6aa50f5051b8f3b5588b50463
DIST nomad-1.2.6-vendor.tar.xz 8019208 BLAKE2B f972a84d201328f95e13a68fdc6dc0f0db5aff6d7ff98f5478ef310c6349fb4c0d9e5aa9c638ae81fb9f2776fa4d252c3b1daed091d3b9ae6d86a75d79e2ac0e SHA512 8d53eaa771847d862f14c3fad286fe42b5c4426b242b18d2b900e4807221e6624b8bb129f34c560078d8863ce19b58c6637d2cc806950fffb5140b8d44f44c8f
DIST nomad-1.2.6.tar.gz 29585632 BLAKE2B 1b9ecbb11ddc59f8078831c6d41b8547a572c3b8475a21d65b8333204bdd2a6ee646cc7c5ec2bdffaee6c1b3cdf2dc30a667464695057e49c2bca41128b61452 SHA512 93a3ed9b0d992ba25cb126496cb9ed250195d8b8011312ebc4cffdf5f9f8786bc43cbe18cefc820597b8a117a05f6118e2e4a88e25e738c1bd309c5504e93ed9
diff --git a/sys-cluster/nomad/metadata.xml b/sys-cluster/nomad/metadata.xml
index 6430362e0106..35a7a677df6a 100644
--- a/sys-cluster/nomad/metadata.xml
+++ b/sys-cluster/nomad/metadata.xml
@@ -6,7 +6,6 @@
<name>William Hubbs</name>
</maintainer>
<use>
- <flag name="nvidia">build with nvidia integration</flag>
<flag name="ui">do not embed the ui in the binary</flag>
</use>
</pkgmetadata>
diff --git a/sys-cluster/nomad/nomad-1.0.9.ebuild b/sys-cluster/nomad/nomad-1.0.9.ebuild
deleted file mode 100644
index 1a271c9eabe7..000000000000
--- a/sys-cluster/nomad/nomad-1.0.9.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 2020-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd
-GIT_COMMIT=958556d77ee6f32d9a92cfbe39ec9d33781b1cdc
-
-DESCRIPTION="A simple and flexible workload orchestrator"
-HOMEPAGE="https://nomadproject.io"
-SRC_URI="https://github.com/hashicorp/nomad/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="nvidia"
-
-RESTRICT=" test"
-
-src_compile() {
- local go_ldflags go_tags
- go_ldflags="-X github.com/hashicorp/nomad/version.GitCommit=${GIT_COMMIT}"
- go_tags="codegen_generated $(usex nvidia '' 'nonvidia')"
- CGO_ENABLED=1 \
- go build \
- -ldflags "${go_ldflags}" \
- -mod=vendor \
- -tags "${go_tags}" \
- -trimpath \
- -o bin/${PN} || die "compile failed"
-}
-
-src_install() {
- dobin bin/${PN}
- systemd_dounit dist/systemd/nomad.service
- insinto /etc/nomad.d
- newins dist/client.hcl client.hcl.example
- newins dist/server.hcl server.hcl.example
- einstalldocs
- dodoc CHANGELOG.md
- keepdir /var/lib/nomad /var/log/nomad
- newconfd "${FILESDIR}/nomad.confd" nomad
- newinitd "${FILESDIR}/nomad.initd" nomad
- insinto /etc/logrotate.d
- newins "${FILESDIR}/nomad.logrotated" nomad
-}